String to Date with slash delimiter

Hello. I have a value from a CSV table. One of the columns is a date, but the date is in this format 01.01.2022. This column is as String.
I’m using Node “String to Date”. The problem is that I’m having an error, because when trying to convert the column to date and mount the format 01/01/2022 (Brazil Locale), Node is accusing an error.

I often use Power Query and am new to Kinime.
And there when changing from String to Date identifies it quickly.

01.01.2022 to 01/01/2022

Hi @Felipereis50 and welcome to the forum.

In the configuration of the String to Date&Time node, can you try using a dd/MM/yy string for the Date format instead?

(Actually, now that I think about it, can’t you just use a dd.MM.yy string before any of the String Replacers?)

If you continue to run into problems, please upload a small sample dataset along with your exported workflow and someone can help further. Screenshots can only do so much :slight_smile:

Hello ScottF.

First I tried to change the dot “.” from 01.01.2022 to 01-01-2022.
After that I tried to change 01-01-2022 to 01/01/2022. (This String change worked.

I had to try this because for some reason the Node String Replacer would not change the “.” to “/” , so I did an intermediation of “.” to “-” to “/”.

After that I tried to use String to date and it still accuses an error.
Output2.xlsx (9.7 KB)

I think you’re overcomplicating things. As @ScottF said, just use the String to Date&Time node with the appropriate date format.

In your screenshot you have the format set to dd.MM.yy

Why is this? It doesn’t match the data you have in the table.

I did this conversion using the format dd.MM.yyyy and it worked fine.


Hi elsamuel

Now I understand.
Visually the format of the date is 2022-01-01 (yyyy.MM.dd)
It’s because I expected 01/01/2022 (dd/MM/yyyy)

Visually, Kimine change the order.

Thanks for the Help

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.