Struggling to open a received workflow

Hi everyone,

I’m a total beginner to Knime. I’m hoping someone can help me out with what must be an extremely simple problem that I’ve just been completely unable to figure out.
My colleague has e-mailed me a workflow to do some work with, but I simply cannot get it to open in Knime so that I can work on it. I’ve got the relevant Excel data sheet and I’ve gotten that as a node into the workflow editor, but I don’t know how to load all my colleague’s work into it.

I’m sorry this is a very basic problem, but I’ve been trying to read all sorts of other help posts and guides but I’ve still not worked it out! I’m usually not so technologically illiterate but I must confess Knime has me a bit out of my depth so if anyone can explain this to me like I’m a 5 year old I’d be immensely grateful!

Hi @SamiSaid40

If you’re using the new UI, go to your local space first.

Click on Import workflow and find the desired file.

If you are on classic UI, go to File and Import KNIME Workflow.

image

Select the correct file by using the browse option.

image

4 Likes

Hi Arjen,

Thanks so much for your help. Unfortunately when I try importing it I get an error message stating “Could not write file”. Any ideas?

Hi @SamiSaid40 , welcome to KNIME!

Could you upload a screenshot of the full error message. I suspect your workspace is set up to write to a location you don’t have permission to write to, such as “program files” folder, in which case a new workspace would need to be selected but I want to check if my thoughts are right.

I know you already said you are a beginner, but have you written or used any other workflows, or is this totally new? Thanks

Oh btw, what operating system are you using, and which version of KNIME?

Hi @takbb, thanks for the welcome!

I’m using Windows, and this is Knime version 5.2. This is the first screenshot I get, I’m then forced to change the name on the next screen.
image

After that I get this:

I had tried to change the location of the workspace earlier but didn’t have any success then either, perhaps I chose two wrong options though.

And to answer your question, yes completely new to this! Not normally needed in my line of work.

thanks for the additional info @SamiSaid40

Ok, the presence of “icon” at the end of the error message (file name) rings bells.

It appears to be similar to this.

Did the workflow by any chance come from a colleague who uses a Mac?

Will the workflow contain any sensitive/private information. If not, you could try uploading the .knwf file here so we can assist with it. Please don’t upload it though if you think it contains (or may contain) anything confidential!

It is possible that you could try what @mlauber71 mentions in that other thread where he says:

“KNWF files are just ZIP files - so you could open them, delete the empty icon files and then pack it again”

but it sounds like that may require further explanation/instruction!

2 Likes

Thanks @takbb, I think you’re right with this! I do believe it was sent from a Mac.
Unfortunately it does have some confidential information so I can’t share it, but I appreciate the offer.
Would you be able to explain how I can open the Knwf files to find the icon files?

The knwf files themselves are actually just zip files so an application such as winzip or 7-zip can extract it into a folder. (It may be easier to rename the extension to .zip first. )

Once that’s done, if you can find the offending file or files and delete them, you should be able to zip the whole folder back up again (using the same zip utility) to a single zip file, then rename that as .knwf and retry the import.

Give it a go and let us know how you get on, or if none of what I just said makes sense, I can try and upload some screenshots to give some pointers when I’m next at my pc. I’m a little vague on the exact files causing the problem but I’ll try to do my best to assist :wink:

@takbb That worked! Thanks so much for your help, I don’t think I’d have ever figured that out.

I’ve managed to load it up and initially found it like this:

I figured the Excel Reader was still trying to read the file from his Mac which obviously is no longer available so I’ve changed to read my exact copy of the spreadsheet saved on my laptop. That’s made it happy but then I encountered the error below:

Not quite sure what it means by it not existing in the input table. As in, it doesn’t exist in the spreadsheet? But then why would it have been working fine for the same spreadsheet on the Mac?
It’s quite unlikely the spreadsheet was changed in the short time between me receiving the spreadsheet and me receiving the workflow, but it is possible.

I’ve played about with it further and seems like it’s only those two Date & Time Difference nodes that are unhappy. If I get them to use other columns everything else executes fine (I just get a nonsensical outcome because of the columns I’m using). Just wondered if you had any thoughts?

No worries if not, I’m extremely grateful for all your help already!

1 Like

Hi @SamiSaid40 , I’d suggest taking a look at the columns being output directly from the spreadsheet and then have a look at the Column Filter. Has that been set to filter out the columns that the Date&Time diff node is expecting? Other than that, I couldn’t really say and would have to suggest going back to the originating user.

Glad to hear you’re at least up and running and hope you manage to get to the bottom of it.

@takbb Looking closely I think it’s instead including columns that don’t exist on the spreadsheet - I must have an outdated version after all. I’ll get that figured out with my colleague.
Thanks again for all your help! All the best.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.