Support for PROXY ?

Dear All,
I'm behind a firewall with proxy authentication. Usually all KNIME nodes work appropriately, for example I can use the Palladian WebSearcher node without problems. However, the GET resource delivers a "java.net.UnknownHostException", typical behaviour of an application that is trying to access directly the target url without using the proxy.

I've also tried "ini" trick of modifying knime.ini adding

-Dhttp.proxyHost=myproxy
-Dhttp.proxyPort=myport
-Dhttp.proxyUser=myuser
-Dhttp.proxyPassword=mypass

and restarting knime ... again the Palladian WebSearcher work well while KREST GET fails with the "java.net.UnknownHostException" error.

Looking forward your reply / instructions / corrections ?

 

 

Hi

 

The PROXY suppport for the palladian nodes is relatively new and works fine. I can confirm this, but I wonder why this does not work with KREST nodes. I habe no problems with the proxies.

 

Therefore I attached a very simple workflow for the Chembl Webservices that uses the KREST nodes.

I have the following preferences in the menu "File -> Preferences -> Network Connections":

  • Active Provider = Manual
  • HTTP activated with host user credentials
  • HTTPS activated with host user credentials
  • SOCKS activated
  • Proxy bypass for localhost and 127.0.0.1

That works fine !

 

Greetings, Frank

 

 

Thankyou for your prompt and detailed followup and for providing details and test workflow.
My settings were slightly different and namely as Active Provider I had "Native".

Apparently, that is sufficient and appropriate for some nodes of knime but not for palladian.

Anyhow, as soon as I switched to "Manual" and then appropriately configured them, then also my workflow worked well.

Thankyou and compliments