Table Row to Variable Loop Start stops after the first iteration when scraping

Table Row to Variable Loop Start stops after the first iteration when scraping

Hello :wave:t4:

I’m using the Table Row to Variable Loop Start to iterate the rows from a table and scrape some text from google search results, but after the first iteration, it just stops and gives me this error with the Send Keys node. I have used this node as I had before, and it used to work perfectly.

It doesn’t take the text from the second row of the table. I don’t know what I’m doing wrong, as I said I used to do it like this and had worked just fine.

I hope someone can help me :pray:t4:

This is the message error:

eclipse.buildId=unknown
java.version=11.0.10
java.vendor=AdoptOpenJDK
BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=es_ES
Command-line arguments: -os win32 -ws win32 -arch x86_64 -data file:/C:/Users/HEIDE/knime-workspace/

org.eclipse.ui
Error
Fri Jul 22 00:53:11 CEST 2022
Editor initialization failed: org.knime.workbench.editor.WorkflowEditor. Site is incorrect.

How many rows does the CSV have?

If there are many, many rows, how about creating a loop that skips the rows causing you errors (seems to be incorrect link structure by the error message). Then go back and do an analysis on the rows (links?) that don’t work.

Something like this (but use the trys for flow variables - not data ports):

3 Likes

Hello.

Thank you for helping me. Actually, I noticed that, in fact, the problem was about the incorrect path for the scraping. The Find Elements node detected two elements for the same CSS path nested in two different places. I just used the Row Filter node and select the one I need and it worked. I’ll be keeping your solution for the future :raised_hands:t4: :raised_hands:t4: :raised_hands:t4:.

Thanks a lot again!!

1 Like