Table View (Javascript) node produces error

it executes well, but when I go to see the interactive view, I get an error and the display shows extra, un-operative column filter rows.

error shown is

DataTables warning: table id=knimePagedTable - Cannot reinitialise DataTable. For more information about this error, please see


The interactive view cannot be opened for the following reason:
unexpected alert open

I can still see and use the view, but with the extra spurious rows.

this is not tied to any particular input data set; happens with all I am using in my workflow


so far I’m not sure what the error might be. Would it be possible to attach a screenshot of what these extra rows look like?
The error message suggests that an popup was opened unexpectedly (e.g. to display an error message) in the view. Was that the case?

There is a popup that is not seen until later, because the interactive view opens on top of it, but it seems to have been generated before. Here it is.

On the interactive view page itself, this error (reported earlier) is shown:

Finally, the view itself looks like this, on its bottom part:

The functionality works on the last column filter row, but not on the other (which are left as just noise on the page).

I am getting a similar error when trying to open an interactive view (see attached image). At first I thought this had something to do with the Selenium nodes installed on my instance of Knime. Is it possible this is related to the latest update of Java?

Hi Christian,

we’ve recently had this issue in the Selenium Nodes as well – it happens when an old chromedriver binary is used with a newer Chrome browser version. See here and here.

Hope that helps,

Thanks Philipp for the reply. I noticed that this is a broader issue and affects all JavaScript views when opened with Chrome v. 64 or newer. We will address the issue with a new bugfix release 3.5.3 which we are hoping to bring out as soon as possible.

A workaround for the time being is to use the Chromium (not Chrome) we ship for Windows as of KNIME 3.5 or on Mac and Linux switch to the internal SWT browser. It says it’s not recommended but that warning mainly applies to Windows users.
To change the browser used for the views, go to Preferences -> KNIME -> JavaScript Views

1 Like

The Chromium solution (I’m a Mac user) worked fine for me; thank you for the suggestion.