Tableau Hyper, send to tableau server in Linux

Dear your help please,

I’m a bit delayed with the publication of information from Knime to Tableau Server using Hyper format, the error that I see is the following.

ERROR Send to Tableau Server (Hyper) 0:2 Execute failed: Unable to initialize Tableau backend ‘Tableau Hyper’, please follow the installation instructions in the node description. Error:java.lang.UnsatisfiedLinkError: Unable to load library ‘TableauHyperExtract’: /lib64/ version `GLIBCXX_3.4.20’ not found (required by /root/Downloads/knime_3.7.0/plugins/org.knime.ext.tableau.hyper.bin.linux.x86_64_2018.2.2.v201811131655/extractapi-linux-x86_64-2018-2-2/lib64/tableausdk/

I have performed the following actions:

The truth is that I do not need it, your help please.

Hi @kmazon,
can you tell me which Linux version you are using? The error indicates that your system’s GLIBC version is too old. Also you should undo the changes done to the variables they are not required and might mess things up in the future.

I know the tableau nodes work for sure with Ubuntu 18.04 and Fedora 29.

Thanks for replying, I’ve been with this error for a long time and I can not solve it.

The version of my Linux operating system is as follows

Regarding what you tell me about the old GLIBC version I updated it following this link

Additional I commented that the topic of anchoring the environment variables I am doing as shown in the following image, I do not know if it is correct, please appreciate your help.

Hi @kmazon,

If I understand software collections correctly, you need to first run scl enable devtoolset-4 bash and then start KNIME Analytics Platfrom from that bash shell.

You should not need to do this, please try without modifying the PATH variable.


Thanks again for helping me, the process I’m doing is the following, as shown in the figure

I do not know what I’m doing wrong.

When you activate a software collection, it is only available within that terminal and all processes launched from it.
In the terminal shown in your step 1, navigate to your KNIME installation folder:
cd ~/Downloads/knime_3.7.0 then start KNIME Analytics Platform with ./knime


I keep presenting the same error I do not know what I need to configure.
Thank you in advance for your time and help.