[Tableau Online] Send to Tableau generating and/or overwriting hyper database files on Tableau Online

I´m having a issue with the “Send To Tableau” node.
The node itself doesn´t show any errors when finishes it´s execution, it shows the “green light”.
The problem is: When its execution is done, and I go to the database on Tableau Online, it´s there, but it´s empty.

The flow:
image

The table that I what to send to Tableau Online:

The “Send to Tableau” node config:

PS: I´ve tried using my “Personal Access Token”, with the same result.

The empty table on Tableau Online (After the node finishes):

How can I fix this problem with that node ?

Thanks.

Hi @rickfadeli , that’s probably due to the fact that you have a column of a ‘date&time’ type, as described in this post:

Have you tried to convert that column to a ‘string’ type first? Using the below node:

I´d had exported to a .hyper file direct on my local machine, then I imported that .hyper file in Tableau, and Tableau had read it successfully.
But thanks for tip badger101, I´ll try it, and I´ll post here the result.

@badger101 I´ve tried, but didn´t worked.

The table, 100% of the columns are on the “string” format:

Tableau showing an empty table:

I see. But at least you’ve managed to upload to the server manually, so all is good.

I can’t think of other reasons for the empty table outcome. Hopefully someone else can look into that issue for you.

Thanks for the attention @badger101 .
But the best solution for this problem, and keep some automation on the process, is generating the .hyper file in the local machine, and then use the “tabcmd” (Tableau Command Line Utility) to send it to Tableau OnLine.

I hope hear some news about the “Send to Tableau Server” node issue.

1 Like