Tableau to Server - Execute failed: invalid UTF-8 sequence

Hi Knime team, I just update Knime to 4.2.0 version, I’m trying to use the node “Send to Tableau Server” and Knime prompt “ERROR Tableau Writer” with Execute failed: invalid UTF-8 sequence (hex ‘4E6F6D6272652043616D7061F161’), but in the old node (BTW appears like a deprecated node) all works correctly.

Could you please tell me what I’m doing wrong?

Regards,

1 Like

Hi @DjAndrw87,

I’ve sent you a message via our official support channel for further analysis of this issue.

Best regards,
Marten

Hello,

Can you please let us know the name of the workbook you are trying to upload?

Also can you test out just a very simple upload with a name like test to the Tableau Server?

What version of Tableau Server do you have?

Could you also set the Knime logs to debug mode from the preferences, then recreate the issue, and upload the knime.log from Knime AP to the case?

Thanks,
Zack

У меня аналогичная проблема:

ERROR Send to Tableau Server 0:2301 Execute failed: Bad Request: There was a problem publishing the file ‘19070:02AFC77BDC0044F3B1B8F3B974939791-0:0’. (Error code: 400011).

ERROR Send to Tableau Server 0:2301 Execute failed: java.net.SocketException: SocketException invoking http://XX.XXX.XXX.XXX/api/2.8/sites/718c1637-4ddd-4cd3-878d-bdb0b5058aaf/fileUploads/13192:733DF51DE7A84C09BF1A4B0A998A7234-0:0: Unexpected end of file from server

Причем, при одних и тех же настройках иногда отправляет без ошибок, иногда с ошибками.
Бывает, что Tableau не понимает кириллицу. Мне приходилось переименовывать заголовки. В целом, проблема сохраняется.
Заметил, что данные могут быть загружены почти на 99% и на 1% - выдается ошибка.

Если попросите выгрузку, то не смогу предоставить - конфиденциальная информация.

Tableau Server - Tableau Server Version: 10.5.12 (10500.19.0122.2242) 64-bit Windows
KNIME 4.2.0

5 минут назад отчет выгрузился как ни в чем не бывало…
Проблему сложно обнаружить… Ощущение, что дело в Tableau. Как иногда есть проблемы с публикацией дашбордов. Без причины выдает ошибку и не публикует. Через какое-то время работает…

Hello,

If you are receiving the error “Bad Request: There was a problem publishing the file ‘19070:02AFC77BDC0044F3B1B8F3B974939791-0:0’. (Error code: 400011)” This is from Tableau’s API, which would indicate that the error is not with Knime but with Tableau not excepting the characters you are attempting to publish your workbook with. Please reach out to Tableau to see what characters they may not except in their publishing API.

Thanks,
Zack

I also meet the same problem? If you solved , could you tell me how?
Thank you!

Well Google gives us this:

Hello,

Let me open up a ticket with our Dev team to investigate the “Execute failed: invalid UTF-8 sequence” as if it worked with the old node fine, then it doesn’t seem to be an issue with Tableau’s side unless they changed something with their API.

As far as the 400011 error, Tableau’s API is not giving us any more details besides this which is very hard to troubleshoot, and especially without any type of logs. If anyone is able to reproduce the error and attach a set of logs, we can attempt to deal with that issue as well.

Here is Tableau’s explanation, which does not say much either:
https://help.tableau.com/current/api/rest_api/en-us/REST/rest_api_concepts_errors.htm

Hi all,

@DjAndrw87, can you provide information about the table you want to send to Tableau? The error suggests a problem with the encoding of strings in your data. It would help a lot if you could provide some dummy data to reproduce the issue.
The old nodes are not deprecated but we encourage the usage of the newer nodes because they are easier to set-up and use the new “Tableau Hyper API”. You can find information about how to use the old nodes in our documentation: https://docs.knime.com/2020-07/tableau_integration_user_guide/index.html#legacy

@jtao6, do you get the error from the original post or do you get the 400011? Can you provide information about how you got the error?

As the 400011 is not related to the original post I would suggest keeping it out of this thread to keep the thread tidy. As the 400011 is a very general error by Tableau we probably need to handle it case by case. If you have a 400011 and think that it is a KNIME error, please open a separate thread and describe thoroughly what you did to get the error.

1 Like


This is the error that I got.

The python script is:

import pandas as pd
import xlwings as xw
import os
from pathlib import Path

df = pd.read_excel(r’E:\结算单查询20200726.xlsx’, encoding=‘utf-16’)
df.结算时间 = pd.to_datetime(df.结算时间).dt.date
df= df.loc[:,[“VIN”,“维修合同编号”,“结算时间”]]
df =df.groupby([“VIN”,“维修合同编号”]).nth(-1)
df[“进店次数”] = df.groupby([“VIN”,“维修合同编号”]).count()
df = df.reset_index()

output_table = df

@jtao6,

Thank you for explaining how you got the error. This will help me to reproduce the issue and fix it.

Encountered this error, and it appears it was related to a column name that was too long for Tableau. Removed the long-named column and the Tableau node executed successfully.

1 Like