Tableau Writer Connectivity Issue

KNIME Version: 4.5.1
OS: Windows Server 2019
Node: Tableau Writer (TW)

I am having some connectivity issues with the TW node at intermittent times of day, the error alludes to the Hyper server connection not calling back. I suspect this is a timeout issue due to resource availability on the machine.


  1. TW plugin’s hyperd.exe has a couple of timeout options that can be supplied to the command that is executed. Is there a way for the user to pass these settings to that executable via KNIME.ini or by some other means so that KNIME uses my additional settings during runtime?
    I would like to explore this setting (which supposedly defaults to 5min): watchdog_timeout

Here is the error in question:

maybe you can wrap your nodes in a try catch with a few iteration in combination with the Wait node

1 Like

That’s a clever idea, would something like this work? What would you say is the most optimal way of doing what you have suggested?

Hi I would think of something similar to your screenshot and end it based on condition. Have you tried your workflow it already?
If so does it work

I have not tried it yet, I am holding off a bit to see if KNIME devs might have some input to the timeout option pass-thru idea.
I think this re-try approach would work for (justifiably) unstable workflows - but Tableau Writer should be a stable functionality, needs a more robust solution.
Also, I suspect this error has more to do with the resources on the machine where I am running the workflow - and that is a separate dilemma in itself that I need to fix.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.