Tableau Writer node stopped working when Knime was updated

Hi folks,

I recently updated knime to 4.3 and had lots of problems trying to download the Tableau extension. After trying many solutions of old topics without results I went to a Knime 4.2.3 version that was appointed by the company I work.

Ok, after that and using the HTTP:// (without the “S”) on the extension sites trick I was able to download and install the extension to my knime. Problem solved, right? NOT

The extension seems fine but simply doesn’t work. I tried a bunch of stuff from older topics without any results. Tried even to use the legacy version of the extension but it doesn’t work anymore either.

These are the error messages

The first time I try to run the newer extension I get this:

On any following trial:

If I try the older version of the extension (deprecated) I get this:

Yes, the SYSTEM PATH contains the line from the node install requirements and C++ was already installed I checked.

Any clue on how to solve? Should I go back to an older version?
Thanks in advance

Hi @DanCGC ,

A few questions to try and better understand your issues:

  1. What version of Knime 4.3 did you upgrade to?
  2. Do you experience the same error messages you sent us screen shots of in 4.3, or these are only from 4.2.3?
  3. How did you install the extensions in 4.3/4.2.3, did you drag and drop or did you download directly from Knime AP?
  4. What were the errors you were seeing when you were having trouble downloading the Tableau Extensions in 4.3?

Can you send us a screen shot of your configuration of the Tableau Writer nodes? You can blur out any sensitive data.

Thanks,
Zack

1 Like

Hi Zack! sorry for the delay. I’ve been overwhelmed by work and I’m using Tableau prep as solution while this node doesn’t function

answering in bold your questions :

  1. What version of Knime 4.3 did you upgrade to?
    I don’t know what do you mean by version. I went to Knime webpage and got the windows 64 file

  2. Do you experience the same error messages you sent us screen shots of in 4.3, or these are only from 4.2.3?
    No. In the 4.3 I couldn’t download the extension even after trying every solution I’ve found online. Only on 4.2.3 that the removing the S in HTTPS solution worked

  3. How did you install the extensions in 4.3/4.2.3, did you drag and drop or did you download directly from Knime AP?
    I dragged from the extension page

  4. What were the errors you were seeing when you were having trouble downloading the Tableau Extensions in 4.3?
    Sorry, I can’t remember what exactly happened but as far as my memory goes it was something like a error message that the extension page could not be accessed

Can you send us a screen shot of your configuration of the Tableau Writer nodes? You can blur out any sensitive data.
This node doesn’t have any configuration. You just select how it will handle cases where the file to be saved already exists. I’m not using any variable so everything is on default

The error messages I posted doesn’t give any clue about why the node is not working?

Thank you!

On the question 4: I’ve just remembered that on 4.3 after the “S” removal solution the extension was found but the installation failed. Can’t remember the reason though. I went back for an early version because before I upgraded the extension was working fine