Teradata DB Writer

Hello forum users,

DB Reader with Teradata DB works good, just add CHARSET=UTF8, otherwise the accents do not appears.

DB Writer… pain point !!!

  • Writing numbers(double): the system asks for the precision. With the Math node, round (xxxx, 2), that doesn’t work either.

    • Workaround : Number to String
  • UTF8 : Non translatable characters are not accepted.

    • Workaround : String Replacer: [^ ÿ]
  • Primary index : it seems that teradata interprets the first column as primary index. When it is not unique, Teradata looks for a secondary index. This causes the writing to fail.

    • Workaround : create a new index-column based on Rowindex + 1

What solution exists to send the information to teradata (Precision, Index (Unique or not), Non translatable characters)

Knime version : 4.2.2
Teradata driver version 17

Many thanks…

Hi @knime_bnv,
I’m afraid at the moment there is no good solution to the topics raised, as we do not have a specialized DB Connector for Teradata.

Hello knime_bnv,
regarding the DB Writer problem, the DB Writer node is a combination of DB Table Creator and DB Inserter node that makes it easy to create a new table and write to it with minimal configuration options. However this might lead to problems with database that are unknown to the framework such as Teradata. So instead of using the DB Writer I would suggest you use the DB Table Creator node to first create the table (see documentation). This way you can influence the data type that is created for each column or KNIME type and thus specify the precision and also specify which columns should be used as primary index. Once the table is created you can use the DB Inserter node.
Regarding the character problem, you might want to try out different type mapping settings in the DB Connector node and also might need to use a special character type for the database such as UNICODE.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.