Text Editor is not support UTF-8 or Any Language ?

I have some porblem about text editor in KNIME (e.g. String Manipulation , Python sniiper , JAVA sniper)

I had changed preference font in Text Editor in encoding to UTF-8 and font suuport “Thai” Language
but KNIME is not show text on locale language.

Could any one help me to setting it ?

Thank you

Have you tried stetting the Workspace encoding to UTF-8 (or UTF-16).



Hi mlauber71,

I try yo settring any more about Encoding but It is not success

I see above your capture may it difference becase of OS but on windows, I setting text encoding UTF-8 is all.

could you provide us with a sample workflow to test?


Sorry mlauber71 for longer reply,

Now I still have problem already. testfont.knwf (12.2 KB)

I will upload the testing font in string manipulator problem and my environment configuration to you. Gofile - Free file sharing and storage platform

I think KNIME did not have font configuration in some component example image from this picture it show L alphabet (L lower)
but my appearance font setting this font all image

and then I used python script node for text this result font is not shown.

result show ASCII result (This may be I not config UTF-8 in my env. I will try)

However, In any editor in KNIME , it should be global config. for appearance right ? If you can help me , I will very thankful to you. :slight_smile:

Is there any solution on this issue yet? I’m facing the same problem with THAI language.

Hi loedbest,

I think my python environment not setting locale THAI( that I will change python prompt to show UNICODE.
I did not try → this is one solution but another issue, I cannot show locale character on KNIME’s console.
I try to change any font or setting but it is not support. (on string manipulate)

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.