The data row has too many data elements.

I tried using file reader and csv reader but I get the message: “Execute failed: The data row has too many data elements.”

I even tried saving tables to disk. Any more powerful node?

Hi @yoshiki3 , I think this error is most likely caused because some lines in the csv file have more data elements on them than other lines.

This can sometimes occur when data contains carriage return characters for example.

As a test can you try ticking the “Support Short Data Rows” option (in the lower half of your screenshot) and trying again to see if that changes anything…

If it then loads your data, hopefully you can scroll down it to see where the problem data is occurring in the file, and fix it.


It made the trick. (Support Short Data Rows). What does it do?

Hi @yoshiki3
The information in the help for the CSV Reader describes its purpose as follows:

Support short data rows

Select this box if some rows may be shorter than others (filled with missing values).

So whilst this has allowed your file to be read, it possibly implies that something is not right with your csv file, and you need to investigate further.

Take a look at the data now returned by the csv reader and look to see that the data that it has read appears correct.
You will probably find one or more rows that are “short” and so will have missing values in some of the columns.

A common explanation is that some of the data in the csv file contains carriage returns that have caused a record to be split across two lines and is therefore being interpreted as two “short” data rows.


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.