"The KNIME Executable Launcher was unable to locate it's companion shared library" when setting up test custom node

Hi all,

I’m working through the Create a Custom Node tutorial (here) and have set it all up correctly (I think…) but now getting the “The KNIME Executable Launcher was unable to locate it’s companion shared library” error message.

Windows 11, KNIME 5.2.3 installed via ZIP. KNIME worked fine before I started making changes.

-Dknime.python.extension.config=Users/Documents/knime/basic/config.yml ← Added to the last line of knime.ini

config.ini ←
org.tutorial.first_extension: # org.tutorial.first_extension from the knime.yml
src: /Users/Documents/knime/basic/tutorial_extension # Path to folder containing the extension files
conda_env_path: /Users/AppData/Local/anaconda3/envs/my_python_env # Path to the Python environment to use
debug_mode: true # Optional line, if set to true, it will always use the latest changes of execute/configure, when that method is used within the KNIME Analytics Platform

I did see there were two other posts from 2020 about this, but I haven’t moved the Application or made any modifications to the structure of the folders.

What am I missing or have I done wrong? I need to get this proof of concept done ASAP and I’m at a loss.

Appreciate any ideas!
Chris

Hi @darthpathos76,

nice that you try it out!

It looks like the path in knime.ini and config.yml is wrong. I would think it should
look like…

  • knime.ini:
    • -Dknime.python.extension.config=C:/Users/...
  • config.yml:
    • src: C:\Users\....

Note the different / and \

Best
Steffen

(and please format code and alike, this helps your companions a lot:)

1 Like

Hi Steffen,
Thank you - KNIME now opens, but when I go to the “Install Extensions” the My Template Node is not there. I’m also seeing the following in the log files:

2024-07-03 14:10:39,019 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  : PowerShell command powershell -inputformat none -outputformat text -NonInteractive -Command Get-MpComputerStatus -ErrorAction Stop | Select-Object -ExpandProperty AMServiceEnabled did not terminate successfully.
2024-07-03 14:10:39,020 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  : Stderr is:
2024-07-03 14:10:39,020 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  : Get-MpComputerStatus : A general error occurred that is not covered by a more specific error code.
2024-07-03 14:10:39,021 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  : At line:1 char:1
2024-07-03 14:10:39,021 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  : + Get-MpComputerStatus -ErrorAction Stop | Select-Object -ExpandPropert ...
2024-07-03 14:10:39,021 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  : + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
2024-07-03 14:10:39,021 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  :     + CategoryInfo          : NotSpecified: (MSFT_MpComputerStatus:ROOT\Microsoft\...pComputerStatus) [Get-MpComputerS 
2024-07-03 14:10:39,021 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  :    tatus], CimException
2024-07-03 14:10:39,021 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  :     + FullyQualifiedErrorId : HRESULT 0x800106ba,Get-MpComputerStatus
2024-07-03 14:10:39,021 : ERROR : main :  : WindowsDefenderExceptionHandler :  :  :

Hi @darthpathos76,

I asked internally, but either way the extension should not be in “Install Extensions”, but in the node repository already. The KNIME Analytics Platform already pulls it (via knime.ini pointing to config.yml, which points to the local extension files) and its nodes should be already be visible.

Does that help already?

Best regards
Steffen

Hi @darthpathos76,

we are quite unsure about the settings of your Windows Defender and are not sure how to reproduce it.

But maybe you find the tutorial node in your repository and the windows defender issue is not applicable to the extension being shown?

Best regards
Steffen

Thanks - I’m wondering if I just won’t be able to use my work laptop for KNIME development. Here’s what I see when I search for “My” in the node list:
image

Really appreciate your time. I’ll start setting up everything on my Mac and see how that goes. Have a good day :slight_smile: Chris

If you switch to classic UI or switch perspective in the preferences to be not the starter perspective, does the node still not show up?