The server selected protocol version TLS10 is not accepted by client preferences [TLS13, TLS12]

Hello, I am trying to connect a SQL SERVER database and I receive this error, has anyone else had this happen to them and do they know how I can solve it?

Hi @Jalvear,

Thank you for contacting us!

I would like to recommend to make sure the correct driver is in-use. It could be used an old version of TLS.
You can try installing a correct JDBC driver.

Also, you can check another related forum post:

Best,
Dzhnahir

Hi @dzhanhir From what I understood from Microsoft, this happens when the SQL server is out of date or the option is not activated. However, I was guided by this MuleSoft Help Center to find a solution that has worked for me at the moment, thanks.

1 Like