The trouble with CSV Reader

Hello to everyone!

I’m trying to read csv-file with nodes File Reader or CSV-Reader. And I get that error:

ERROR CSV Reader 3:1 Execute failed: -276964106

Can you help me with that error?

I’m trying to read all column like string, but the error persists.

Hello @greatvarona ,

is there a reason for which you need to skip the first 11M rows?
It’s difficult to say what can be. Could you provide more information?

Thank you and have a nice day,


You have only provided a small snapshot of the affected row, so it is difficult to say whether the error matches a different column in the file. Also, as KNIME couldn’t read the row it is less likely to appear in the table and you may need to search through the input file to find the row that generates the error.

You can easily print the affected portion of the file using PowerShell Get-Content and Select commands. The following command will skip the first 11,377,550 lines and then print the next 10. You can install PowerShell on Windows, Linux, Mac. It has many useful commands for managing data files.

Get-Content my-big.csv | Select -Skip 11377550 -First 10

You can also output a sample of the data to make it easier to run tests so that you can localise the problem.

Get-Content my-big.csv | Select -Skip 11377550 -First 10 | Out-File "test-data.csv"

If you are running the test file, you may want to check what column types are suggested. I have often had problems with files where the data scanned to determine column types is correct, but a change in data occurs later in the file. Under the Advanced Settings tab there is a section Table Specification that limits the data rows scanned. Note, data is always scanned from the start of the file, and ignores skipped lines. This is why I suggest extracting a sample of the data around the line that creates the error. You don’t want to wait for ~12m lines to be scanned to locate the problem, 10 lines is enough.

Hope this helps


Hi @greatvarona
There is an option
support short data rows
this often helps

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.