Timestamp Alighment


I am trying to use TimeStamp Alignment node to align my time series and pay attention to missing dates but the when TimeStamp Alignment node is not even showing any of the column names. I have attached the error and configurations pictures for your reference.

Hi @priyanshijain98 and welcome to the forum.

This error usually happens because the table being input to the Timestamp Alignment component doesn’t have a valid datetime field available.

Are you sure you have a valid datetime being output by your String to Date&Time node?

Yes my input datetime field is according to the configurations for the input port. I even converted my string type date to Zoned Date Time using Python but same error is occuring again and again.

Can you post a sample workflow along with some dummy data that reliably reproduces the error?


I have uploaded the worklow image and a sample dataset which is giving me the same error. I have used default configurations for all the nodes.


Very strange. I’m able to get it to work using your sample csv file, but I’m using Windows OS (although I’m not sure why that would matter).

Are you able to run the attached workflow successfully?

TimestampAlignmentTest.knwf (77.4 KB)

2020-10-30 10_06_31-KNIME Analytics Platform

1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.