Track Spots ThreadPool and Null Error


I was trying to use the FMI-IJ2 plugin (GitHub - fmi-faim/fmi-ij2-plugins: A collection of ImageJ2 plugins for use with KNIME) to use TrackMate for my particle tracking. I loaded my images with the image reader node and feed into the Track Spot node. It used to work perfectly, but from 2 weeks ago, it started to give the following message:

ERROR ThreadPool An exception occurred while executing a runnable.
WARN Track Spots (Subpixel localization) 0:438 Error while executing row: xxx.tif! Cause: null

xxx will be my file name.

I have tried many ways to fix this: (1) I tried to update KNIME and the package; (2) I tried to uninstall and reinstall KNIME and the package; (3) I tried to run the same workflow on another Mac (I was using a Mac when having the workflow worked); (4) I tried to run the same workflow on Linux; (5) I tried to run different versions of KNIME from release in 2019 to now.

ALL of the above trials failed… On Linux, it won’t give the first line of error message, but just the second line. Also, I noticed that the number “0:438” will change in different versions.

Any comments or suggestions will be highly appreciated!

Hi @gmgao,

wow, you have covered a wide spectrum of debugging tests! Would it be possible to build a very small workflow with a single image that runs into this issue? And does that issue occur with every image, or just one specific .tif?

If you could share the small workflow, that would surely be a great help to pinpoint the issue.

Kind regards

1 Like