Trackmate node misses some time frames

Hi,

I’ve been trying to use the Trackmate tracker node to follow cell nuclei and spots. Everything works fine for spots but I run into a strange problem when tracking nuclei.

For every frame I can generate a segment bitmask and all features. However, when I run the output of the segment features node into the Trackmate tracker I lose a few time frames. Trackmate just produces a blank label image for those time frames.

From playing around I know that it is something in the image that is causing Trackmate to miss the frames as it will always happen to the same frames. However, there is no obvious culprit and simple things like Gaussian blurring the image doesn’t solve the problem.

Does anyone know what would cause the Trackmate node to miss these frames?

I changed the alternative linking cost factor settings but that doesn’t improve the situation.

Workflow attached below with an example image:


Workflow: Trackmate_missing_frames.knwf (1.7 MB)
Example image: Timelapse_nuc_foci-1.tif (1.9 MB)

2 Likes

Hi @aseeber,

Thanks for providing the sample image and workflow – this has made the investigation quite a bit easier. Unfortunately, I currently don’t see an obvious reason, why the Trackmate Tracker should miss those cells. Will have to debug into this issue which might take a couple of days.

Best,
Stefan

2 Likes

Thanks a lot @stelfrich. It’s a weird issue. A couple of other points that may help:

  1. Tracking the same thresholded imaged in Fiji with Trackmate works just fine.
  2. It seems to be a generic issue. I’ve tried a few different data sets now (moving nuclei, worms, etc) and the problem shows up.
2 Likes

While I’m reporting Trackmate tracker node bugs, I may as well report another similar issue:

For some tracks, the Trackmate node will split a track into 2 tracks even though there is no obvious reason why it should do so. Even when the “Maximum distance between objects” is maxed out to be larger than the image itself, this is not resolved. Likewise, enabling “Track merging” and changing the distance/gap settings cannot force the tracks to become one.

Has anyone else encountered this or know why it happens?

Below is a sample workflow and image of a spot through time showing this issue:

Workflow: Trackmate_not_linking_spots_export.knwf (471.5 KB)
Image: Spot_short-3.tif (2.9 MB)

2 Likes

Thanks @aseeber! The same issue is underlying your both reports which I was already able to fix. Getting this into a release will take some time though, since our master of packaging is currently on vacation! Will keep you posted in here once a release is available.

6 Likes

Thanks so much @stelfrich. I’m really glad you were able to find and fix what was causing the issue :smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.

Hi @aseeber,

We have just released a new version of KNIME Image Processing (1.8.1) that includes the aforementioned bugfix. While I have confirmed that it works with your provided workflow, I’d appreciate feedback if this solves your issue!

Best,
Stefan

PS: Thank you @gab1one for packaging the release and Jean-Yves Tinevez for the pointers and fix!

3 Likes

Thanks a lot @stelfrich @gab1one @tinevez!

I’ll update and be testing that work flow over the next week. I really appreciate the effort to fix that bug.