Transfer Files node won't accept knime:// path for destination


I’m trying to use a Transfer Files node to retrieve a copy of a file and store it in a data folder within the workflow. So, what I want is to give the node a destination of knime://knime.workflow/data/input but it doesn’t work.

There isn’t an option for Custom/KNIME URL in the Write to dropdown box. That option is in the Read from dropdown box for the source though.

Does this node not support writing to knime://... paths? If not, could that option please be added?



I don’t seem to have the Custom/KNIME URL option in the List Files/Folders node either, which seems odd.

Hi @rsherhod , if you want to point to the workflow’s data folder, you can use the option Relative to.

EDIT: Here’s an example workflow I put together for you: workflow data folder.knwf (9.7 KB)


indeed the only occasion where the transfer/copy could support knime-protocol is when using the Transfer File (Table) node.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.