Trouble installing HCS Tools from zip archive

Have trouble installing the ‘HCS Tools’ extensions on an office PC of mine. Since it’s behind a restrictive firewall, I use the zip archive for the extensions (on a company laptop with apparently less restrictions everything runs fine), but I end up with this error message:

Cannot complete the install because one or more required items could not be found.
Software being installed: KNIME HCS Tools 4.0.0.v202007151505 ( 4.0.0.v202007151505)
Missing requirement: HCS-Tools for KNIME 4.0.0.v202007151505 (de.mpicbg.knime.hcs.base 4.0.0.v202007151505) requires ‘osgi.bundle; nu.xom 1.2.10’ but it could not be found
Cannot satisfy dependency:
From: KNIME HCS Tools 4.0.0.v202007151505 ( 4.0.0.v202007151505)
To: org.eclipse.equinox.p2.iu; de.mpicbg.knime.hcs.base [4.0.0.v202007151505,4.0.0.v202007151505]

Apparently there’s a dependency that cannot be satisfied. Is there any way to fix this?

Hi, which KNIME version do you have?

I tried to find a download source for the missing jar but I could not find one.
I understood that you have an installtion on another machine which does not have that issue? Can you copy/paste the following jar from the plugins-folder of that installation and put it into the plugins folder of the installation which does have the issue?



1 Like

I copied over the jar file and that worked nicely. Thanks!
I was considering copying the whole installation from the laptop to the office machine, but this was much easier.

1 Like

I’m glad I could help! :grinning:

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.