Trouble loading Excel File with excel reader node

Hi guys,

I’m using KNIME 4.0.0 version and I’m unable to load a file with the excel reader node because it doesn’t recognize any sheet names and I cannot write it, so when I try to apply it says invalid settings please select worksheet.
I already tried loading the same file in both .xls and .xlsx format and its the same problem.
In CSV its the only one that read it but it changes the type of my variables so I want to fix the problem with the EXCEL READER NODE.

Anyone knows how to solve this?

Sounds like this is a CSV file with xls extension. Can you open the file in a Notepad or something?

No, its an Excel file I created it in SPSS modeler with an excel output node and a xlsx extenssion.
When I wrote that I could read it in CVS it was because I opened the file in Excel and save it as CVS but doing so changes the type of the features in my file so it didn’t solve my problem.

Sounds strange. It has been a while since I worked with SPSS. What you could do is try to load the file with an R package.

Also Excel might not be the best way to keep the types of variables. Does SPSS offer options like SQLite or Parquet which might be better suited for the task (and also KNIME can read them).


Hi there @Cpalomeque,

you can always share file and someone can test it. If you are dealing with sensitive data delete that data and write dummy data in your file. Then check if you are having same behavior with dummy data and if so upload it and as said someone will check it :wink:


1 Like

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.