Try-catch abnormal behavior

Hi everyone,

I am working on a workflow and I am facing dysfunctionality for using try-catch error nodes in an inactive port.

To clarify my explanation, I have a workflow with empty table switches and within each of them I have one component with multiple try-catch error nodes in it. As a normal behavior when the component is in the inactive port, I expect the component should be inactivated and the end if node should choose one of the ports and be run after it; but when I run the “End if” node it is not going to run and my workflow does not proceed anymore.

It is so strange because it shouldn’t act like this.

Normal behavior:

Although I can not share the exact workflow but this is an example for the workflow structure that I am working on, I have tried to face the same error in this workflow but I could not.
Try-catch.knwf (45.1 KB)

So, if anyone can help me with this error I would be appreciated.


Do you see any error message? Could this be the issue described here?


Hi @qqilihq,

Thanks for your quick response.
Actually I don’t face any error in my workflow so I can not understand what the exact problem is; but for the bug that you have sent your work face error in the try-catch error nodes but in my case the whole work is in inactive port so no nodes should be active anymore.


Hi @monaJZ , I tried your sample workflow, and it’s working “normally” for me. I am not able to reproduce your issue with your sample workflow.


And this is how the component looks like:

Zooming on the part you showed:

It looks like it is behaving as expected, it’s not going through the loop, nor through the component, and the End If node does not complain and is able to finish executing.


Hi @monaJZ , OK, I’ve been able to reproduce what you have showed, but this not an issue. You achieve this by running the workflow up to Empty Table Switch:

Basically what you are looking at is the initial state of the nodes that have not run yet, including that’s in the component. But if you run any nodes after, be it the ones in the Component, or the Loop End, or the End IF, it will execute properly and complete successfully.


Hi @bruno29a,

Thanks for your response.

Actually yes the workflow that I have sent is working well. And for the next response, in the main workflow that I am working on (not the sample one) I’ve run all the nodes and it has shown me running them but at the end it’s like the picture that I have sent, it’s going to be red or in some cases it remains yellow.


Hi @monaJZ , it will hard to comment without seeing the workflow.

1 Like

Hi @monaJZ,

If you have any Breakpoint node in the inactive branch and they are using flow variables which are generated in the branch, Make sure you provide a fake variable before the switch node passed to the branch.

@ScottF I think this issue is unexpected: When we use a Breakpoint node in an inactive branch and we use a flow variable in it which is generated in the branch, the Breakpoint node still looks for the variable and if it doesn’t find it, the branch would fail (actually the switch will not be closed). I think the Breakpoint node shouldn’t look for variables if it’s in an inactive branch.



Hi @armingrudd,

Thanks for your response.
That’s the solution for this dysfunctionality. It’s working really well now.



Interesting, thanks @armingrudd . Do you have (by chance) an immediate example workflow to see that in practise?

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.