Twitter OAuth Error

Hey everybody,

I'm trying to get twitter data via the palladian websearcher (tried it with the provided sample workflow: TableCreator-WebSearcher which already includes some data). As soon as I try to retrieve tweets myself, after following the instructions here, I get an authentification error:

[{"message":"Bad Authentication data","code":215}]}

or the whole error:

( HTTP error 400 for request HttpRequest [url=https://api.twitter.com/1.1/search/tweets.json, method=GET, headers={Authorization=OAuth oauth_signature="aSIqWyh5x%2BmFkpaQpSRvBeuRWlU%3D", oauth_version="1.0", oauth_nonce="b2081d808ada6a6f4ac715cfecf55df6ab6c57ff", oauth_signature_method="HMAC-SHA1", oauth_consumer_key="cMj8uuKUkOQarlwRahK2zdfT0", oauth_token="%202522309557-ONeDuZI4pH01lvtUcLtqsjPZmuJQPMcUgAUvfRn", oauth_timestamp="1402909044"}, parameters={count=10, q=#allin, lang=en}]: {"errors":[{"message":"Bad Authentication data","code":215}]})

I tried renewing my access tokens in the Twitter Application but I keep getting the same error.

I might be doing something completely wrong (or more likely missing something as I followed the instructions precisely).

I appreciate any help, thank you!

Hi Pepita,

looks like there is a superfluous space character at the beginning of your OAuth access token. Can you double check the input in the preferences?

Hope that helps, if not, let me know.

Best,
Philipp

 

geez. I double checked for empty spaces inbetween and at the end but never guessed there could be one in front (as all the tokens had one space character in front). I feel incredibly stupid now. Thank you!

fyi: No worries, the same problem also happened to me once :) To avoid those pitfalls, newer versions will strip leading/trailing whitespace automatically in the API key prefs.

Best,
Philipp