Unable to connect to database

Yesterday I installed Vertica extension and connected successfully to Vertica DB using Vertica Connector node. Today while doing the same I am getting an error saying “Invalid settings. Please select a driver name”.
Why is the configuration asking for driver when the connection was successful yesterday. Also is there a way to save my DB connections permanently.

Hello @yash,

were you trying to execute node you configured yesterday or was it “new” Vertica Connector from Node Repository you were trying to execute without configuration?

Br,
Ivan

@ipazin Thanks for your reply. I couldn’t find the workflow created yesterday in my workspace. So I tried to create a new Vertica connection with same credentials used the other day.

Hello @yash,

I see. So if you pulled a node from repository you need to configure it including driver name, credentials and other info as node can not inherit configuration like that. To store DB connections parameters “permanently” you can wrap connector(s) in Component and share it. See here:

Br,
Ivan

Hi @ipazin,

Yes I tried to configure by entering the credentials but the driver name option is greyed out and I don’t see anything in the dropdown as well. And I am sure I have not filled anything for driver name yesterday.

PS: I have a SQL connector as well and by default I had a driver name while configuring.

Hello @yash,

driver option grayed out for me both in Vertica Connector and DB Connector node (if that is the one you were thinking of). Reason for that is missing driver registration. See here on how to register your own driver:

Have you maybe done it yesterday? If not then wondering how did it work…

Br,
Ivan

Thanks for that. Let me try out but even I am wondering why it is required now. yesterday I configured the connection and read the data using DB Reader node also without this driver.

Hello @yash,

maybe I got it. When you said you yesterday installed Vertica extension you probably installed KNIME Vertica Driver extension.

VerticaDriver

Also do you maybe have multiple KNIME instances on your machine? That would explain why you can’t find workflow from yesterday and why is driver option grayed out (cause extension is not installed).

Br,
Ivan

@ipazin Perfect. I installed the extension again now and I could see the driver name while configuring and the connection is working now. Thanks a ton. And I don’t have multiple instances but wondering why this happened.

1 Like

Hi @yash,

glad to hear it’s working now. Also puzzled about that one but let’s hope won’t happen again.

Br,
Ivan