Unable to connect to Knime Server after 4.6.2/4.6.3 update

Hey,

After updating to 4.6.2 and 4.6.3 on mac os i am unable to connect to our Knime Server instance.
I have tried implemented fix as describe in this video (Resolving Common KNIME Certificates Problems - YouTube) but error still persists.
Also colleagues using windows are not seeing this issue.



Any help would be greatly appreciated.

The KNIME Server’s certificate is not accepted by your local AP installation. In case you are using a self-signed server certificate or a certificate signed by a non-public CA you must install the certificate into the AP’s certificate store. See KNIME Server Administration Guide for details.

2 Likes

Hey @thor, i have tried your suggestion but still no luck.

Through some experimenting i have discovered this only occurs with a fresh install of Knime. If i install 4.5.2 and then update to 4.6.3 via the application i do not receive this error. However install 4.6.3 directly i get this error.

Hi @ajc,

thanks for the update. I’m afraid I can’t reproduce the behavior.
If you’d like to dig further, we would need quite a bit of info on what SSL certificate your server is using and whether you have custom KNIME installations or update sites.
For instance, if you download KNIME from a company internal site, you might have a changed knime.ini that instructs KNIME to use Windows certificates.

Given that updating 4.5.2 seems to work, I suggest we only look further if need be.
Since this likely is an individual problem, I suggest reaching out to support@knime.com, should you want to further investigate the issue.

Kind regards
Marvin