Unable to connect to Open AI Node Authenticator via Credentials Config


I am trying to connect via the credentials configuration to the OpenAI Authenticator. It returns the message “Invalid API Key provided”.

However, when I run the query via Post request, the API Key works. Therefore, I believe that there must be a problem with the way I am entering the parameters in the credential configuration.

Should it be like this?



Hi @Charlie20,

I’ve tried to reproduce the error but I couldn’t. Here is how you should configure your Credentials Configuration node:

To help identify the problem, here are a few things you could check:

  • Can you tell us what KNIME version are you using?
  • Can you double-check that you’re copy-pasting your API key correctly? (No blank spaces, etc.)
  • Can you double-check whether you’re passing the correct flow variable to the OpenAI Authenticator node? In my case the correct flow variable is called “credentials” (see the field “Parameter/Variable Name” in the screenshot above).

Hope it helps,


Thank you very much Roberto. This is very helpful.

I was confused with the user and password ID needed to access the OpenAI account. For what you mention, only the API key is needed and is entered as “password”.

That fixed the problem.

1 Like

Yuppi, nice to hear that! :slight_smile:

Happy KNIMEing,

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.