Unable to do Chunk Loop- unable to read other excel

Hi,
I need a little bit advice. I try to do chunk loop but it unable to loop other excel. There were no error message but it seem not looping other file.


Hi @ShirleyN7, welcome to the forum.

It’s hard to tell what’s going on just from a screenshot; we’d need to see how all the nodes are configured. What’s happening at each steep?

Personally, I would simplify the whole workflow to something like this:
image

The Excel Reader node will accept a Path flow variable, and the Table Row to Variable Loop Start node will cycle through all the files given to it by the List Files/Folders node.

3 Likes

I would like to combine all my excel into 1 excel file. However, it will only read 1 of the file.



The result still shows only read 1 file. It give the same file loop result instead of combining the 4 file.
image

What function should i use? or setting should i amend?

Hi @ShirleyN7

You need to configure the excel reader to use the flow variable:

You might need to increase the size of the config window to see that option.

best,
Gabriel

4 Likes

Aaahhh, yes it’s working. Thanks!

1 Like

Hi @ShirleyN7 , you may also be able to do what you’re trying to do with just the Excel Reader alone, without any loop.

There is the option “Files in folder” where you can just point to a folder, and the Excel Reader will open all the files in that folder:

You don’t need to open one by one through a loop.

EDIT: You can configure these 3 items in your Excel Reader like this:

The Excel Reader will open the 4 files you have there (a.xlsx, b.xlsx, c.xlsx, d.xlsx) for you, no need for loop.

2 Likes

Hurm,

It’s not working tho… is there something wrong with the data?

It’s giving me an error:

ERROR Excel Reader 4:375 Execute failed: The following columns are not contained in all source files: [ColumnA, Column B, Column C, Column D]

Actually, I want to get an output like this but instead of few column, I want it in 1 row. I saw there are an example reading thru sheet and other excel, but i couldnt figure how it done. Sorry, im kinda new with knime so im not quite familiar with the node …

image

Hi @ShirleyN7,

Looks like your Excel files have different column headers, if you deselect the Fail if specs differ option and select the Support changing file schemas in the advanced tab, you can see the output table KNIME AP will generate for you:

image

Then you can play with the column name and starting row options in the settings to get it to generate the table you want

image

best,
Gabriel

3 Likes

Hi @ShirleyN7 , this is because your files have different structure/headers, as pointed out @gab1one, who also pointed out how to configure the Excel Reader to handle this.

Regarding how you want the data to be:

I don’t understand what you mean by 1 row. Could you give us an example of what you want to see?

1 Like

Thank youuuuuu !!! Yes, It’s working now and I got the result that I want. Thank youuuuu :heart_eyes:

2 Likes

Yes, I just realize it because of the header column is different hence cause it error. I use the setting as @gab1one suggested and I got the result that i want. Thank youuu :smiling_face_with_three_hearts:

1 Like