Unable to import GKN Nodes into KNIME SDK

I am currently working on creating nodes for command line tools and for this purpose I use Generic KNIME Nodes (https://github.com/genericworkflownodes/GenericKnimeNodes).I have to say the documentation is sparse so I might have easily overlooked something. I am currently using the 3.8.0 nightly build on Win 10 pro.

After creating the eclipse plugin via ant I am able to import the resulting directory into my eclipse workspace but i get several error messages. After then starting the KNIME instance none of the new Nodes appear where they are supposed to. Tried this already with the samle projects (openms, copyfasta etc) and my generic hello world node.

I am using the AP-complete.target which includes File Handling Nodes. After starting eclipse the target platform has to be reloaded multiple times to get rid of error messages.

Hi @sattayan,
I think I figured out what is going wrong there, you are missing classes from the genericworkflownodes projects.

To fix this, you need to either import the com.genericworkflownodes.knime and com.genericworkflownodes.knime.config projects into your workspace, or add the community update site to your target platform and select the genericworkflownodes plugin from there.


Thank you for your answer. Unfortunately I’m still running into the same issue after importing the required bundles. Does it work for you? Which platform are you on?

I also tried cleaning and refreshing all projects but it doesn’t help.

I see the problem, you imported the projects incorrectly, you can see that they do not show up as eclipse projects in your Project Explorer. You should use the Import Projects from File System or Archive import wizard and only select the projects you need:


That was quite helpful thank you. Meanwhile I figured out how to get GKN working as well. I will post an updated tutorial soon as the current ones are not quite working.

1 Like