unable to INSERT data into Oracle database

I’m using KNIME 4.1.2 and try to insert data into Oracle Database 11gR2 (using ojdbc6.jar from 11.2-client).
Tried with DB Insert, DB Writer, DB Loader, but with no success. The amount of data doesn’t matter, tested with 1,10,1000 records for INSERT.
In most cases the node executes infinite time, but no data get’s inserted.
Also tried with debug output in KNIME, but got no relevant information from this.
What’s wrong in my case?


Hi there @ReWi,

can you try writing INSERT SQL statement in DB SQL Executor node and see does that work? And reading data works fine or problems there as well?


1 Like

Hi @ipazin,

thanks for your reply.
I’ve tested DB SQL Executor node (only one small insert, 1 row) but encounter the same issue: node runs endlessly.
Reading of data works perfect.
The database user has rights to INSERT.

Any ideas?


Hi René,
can you change the driver to the latest ojdbc8 driver from Oracle (for more details see here). Do you experience the same problem when inserting data into the same table using another tool? How many rows are in the table? Maybe you experience a problem as described here.

1 Like

Hi @tobias.koetter,

thanks a lot. Yes, with latest ojdbc8 INSERT works with DB Writer and DB Insert nodes.

Thanks again,

1 Like

You are welcome :slight_smile:
I will mark the thread as closed.