Unable to install Geospatial extention in version 5.1.2


I have seen other questions related to this but they seem to reflect another situation.
My issue:
I updated KNIME to version 5.1.2 and wanted to install the geospatial extention. With that I received this error message:


How could I fix that?
Any suggestions would be appreciated!



Hi, could you follow through this post?


Hi Steffen,

many thanks for your reply.
Unfortunately I do not have admin rights so cannot change the configuration.

But here the error log, if that brings anything additional.



Hi Ivan,

Please follow through the post, there is a link which describes how to obtain additional error logs.
At the same time, as this seems to be a long path issue, you could try to put your KNIME installation into a folder which has a shorter path.
Lastly, if you wait for 5.2, this issue is less likely there.

Best regards

Hi Steffen,

tried a with a shorter path but that does not seem to work either.

Here the error log in the plug in folder:

Do you know when 5.2 will be available?



I think the tentative date is 6th of December.
Could you please provide the log you have just shown as a text file and also the create_env.out (as text file)?

create_env.err.txt (312 Bytes)
create_env.out.txt (51.7 KB)


thanks for the info.
Hope to find a solution sooner than 6/12, if necessary I will downgrade again to 4.7.7 which I was using before.

txt files in attachement.



Thanks for the logs!

Unfortunately, we have never encountered this issue before.
Are you saying that with 4.7 you can install and use the Geospatial extension? If yes, I suggest using 4.7 for now until we can come up with a fix. Could you please confirm that it works with 4.7?

I opened a ticket (AP-21530) for this issue. Maybe @bwilhelm has an additional thought.

Sorry for these inconveniences


I can confirm that I was able to install and use the extension on 4.7.7.
However, to complete the story.
The reason why I updated to 5.1.2 is the following:
Everything worked fine in 4.7.7 except that the Google Distance Matrix node gave me zero distance and time as output. (Error message was something in the sense of: output spec didn’t match expected format.)
On my personal PC I have 5.1.2 and there the Google Distance Matrix node worked fine
hence the decision to update to 5.1.2 on my work PC.



1 Like

Hi @IvanFL,

Could it be that your work PC is behind a proxy or has some special certificates configured? I googled around a bit and found this post (technical detail warning :wink: ) SSL certificate issue when connecting to repos (conda handles certificate with no problem) · Issue #1106 · mamba-org/mamba · GitHub. We did update the version of micromamba which we use for conda environment installation, probably that’s why there is a difference between 4.7 and 5.1.2. But the update of micromamba should have fixed the issue, not made it worse :confused:

If you set this environment variable, does that resolve the issue? MAMBA_SSL_NO_REVOKE=1


Hi Carsten,

many thanks for the reply.
Yes, my work PC is in a well “protected” environment.

The solution you are offering is a bit technical for me … .
If it can help you figure out the general issue maybe we could have a look via Teams?



This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.