Unable to integrate DB connector into knimpy execution


i’m trying to run a workflow with an impala connector via knimpy. However, the appropriate database driver is not found by the workflow preferences. The database drivers are created in the preferences via KNIME/Databases. I think this is the same problem as in: Failure to run workflows with Database Connector (Oracle) from Jupyter Notebook . But I don’t know how to get the driver manually into the knime.ini.

ERROR:root:captured stdout: CompilerOracle: exclude javax/swing/text/GlyphView.getBreakSpot
Install location:
file:/c:/Program Files/KNIME_400/
Configuration file:
file:/c:/Program Files/KNIME_400/configuration/config.ini loaded
Configuration location:
file:/c:/Program Files/KNIME_400/configuration/
Framework located:
file:/c:/Program Files/KNIME_400/plugins/org.eclipse.osgi_3.12.100.v20180210-1608.jar
Loading extension: reference:file:javax.transaction_1.1.1.v201105210645.jar
eclipse.properties not found
Loading extension: reference:file:org.eclipse.osgi.compatibility.state_1.1.0.v20170516-1513.jar
eclipse.properties not found
Framework classpath:
file:/c:/Program Files/KNIME_400/plugins/org.eclipse.osgi_3.12.100.v20180210-1608.jar
file:/c:/Program Files/KNIME_400/plugins/
file:/c:/Program Files/KNIME_400/plugins/javax.transaction_1.1.1.v201105210645.jar
file:/c:/Program Files/KNIME_400/plugins/org.eclipse.osgi.compatibility.state_1.1.0.v20170516-1513.jar
Debug options:
file:/U:/.options not found
Time to load bundles: 16
Starting application: 1109
WARN main Node Loading model settings failed: Could not find the [Impala_41] database driver.


with knime.Workflow(workflow_path=workflow,workspace_path=workspace) as wf:
wf.data_table_inputs[0] = df
df_extract = wf.data_table_outputs[0]

I solved the Problem, you just have to add the -preferences with the path to your preferences file after line 242 in knime.py.

1 Like

Glad to hear that and tnx for sharing it @jH2020!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.