Unable to run Knime due to Configuration error

Just installed Knime 3.3.2 and worked fine the 1st time I ran it. Now whenever I try to run Knime it shows a configuration error and doesn't run. I have copied the configuration log file below and attached the knime.log.

Can someone help me to fix this? Knime is such an awesome software, it's a pity that I can't run it.

------------------------------------ log file -------------------------------------------------------------

!SESSION 2017-06-20 15:10:17.749 -----------------------------------------------
 java.vendor=Oracle Corporation
 BootLoader constants: OS=win32, ARCH=x86_64, WS=win32, NL=en_AU
 Command-line arguments:  -os win32 -ws win32 -arch x86_64

!ENTRY org.eclipse.osgi 4 0 2017-06-20 15:10:20.282
 !MESSAGE Application error
 java.lang.UnsatisfiedLinkError: org.eclipse.swt.internal.C.PTR_sizeof()I
  at org.eclipse.swt.internal.C.PTR_sizeof(Native Method)
  at org.eclipse.swt.internal.C.<clinit>(C.java:19)
  at org.eclipse.swt.widgets.Display.<clinit>(Display.java:138)
  at org.eclipse.ui.internal.Workbench.createDisplay(Workbench.java:773)
  at org.eclipse.ui.PlatformUI.createDisplay(PlatformUI.java:160)
  at org.knime.product.rcp.KNIMEApplication.createDisplay(KNIMEApplication.java:190)
  at org.knime.product.rcp.KNIMEApplication.start(KNIMEApplication.java:101)
  at org.eclipse.equinox.internal.app.EclipseAppHandle.run(EclipseAppHandle.java:196)
  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.runApplication(EclipseAppLauncher.java:134)
  at org.eclipse.core.runtime.internal.adaptor.EclipseAppLauncher.start(EclipseAppLauncher.java:104)
  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:388)
  at org.eclipse.core.runtime.adaptor.EclipseStarter.run(EclipseStarter.java:243)
  at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
  at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
  at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
  at java.lang.reflect.Method.invoke(Method.java:497)
  at org.eclipse.equinox.launcher.Main.invokeFramework(Main.java:673)
  at org.eclipse.equinox.launcher.Main.basicRun(Main.java:610)
  at org.eclipse.equinox.launcher.Main.run(Main.java:1519)

Hi dataengineer,

Really sorry that I missed your last reply!

My best guess is that this is related to a virus scanner due to which the startup times out.

There are two options that you can try. Either adding the knime.exe to the 'whitelist' of known programs in your virus scanner software, or adding the following newline in the knime.ini file that is found next to the knime.exe:


The first startup of the KNIME Analytics Platform might take a while, whilst the virus scanner works, but subsequent launches should be much faster.


If this doesn't help, you can also try to add this entry to the top of your knime.ini:


Next, start KNIME Analytics Platform again. You can then remove the "-clean" again.


Edit: If this also doesn't help, please try to install only the base version of KNIME Anayltics Platform (without all extensions) and only install the extensions you need.