Unable to save_as workflow due to File access problems Math Formula node (Access is denied)

Hi,

when trying to save a new version of my workflow I receive the following message:

File access problems: C:\Users\Me\Onedrive- …\Workflow\Math Formula (#863)\port_1(Access is denied)

This is a node that has not changed compared to the previously saved version.
I have even deleted the node but still get the same error message.

When I look in the workspace the workflow has been saved as a group instead of as a workflow.

Who can help?

It might well be that there will be problems with special characters in some folder name configurations of MS OneDrive. If this is the case you will not be able to recover from this. You have to save your workflows and move to another workspace!

image

2 Likes

Hi mlauber71,

many thanks for the replay.

I do not have # in my workflow name.
The # comes in the error message to indicate the number of the node in question.
Just tried to reduce the length of the workflow name but that does not help either.

@IvanFL the hash (#) is used to indicate node numbers internally for KNIME, so they will always be there regardless of what you do. You should test if your OneDrive does allow that character. If not you will not be able to store KNIME workflows there and I would strongly advise not not use this sort of folders!

Since we are at it, you can read more about KNIME tuning and performance here:

Hi,

agree that it probably has something to do with OneDrive.
But I am using OneDrive since ages and only occasionally have this issue.
I have never issues saving the workflow just with save_as.
Just tried to publish to the KNIME server and then save_as in OneDrive under a new name and that works perfectly.
Maybe that would be a workaround.

1 Like

@IvanFL if your OneDrive would support that and has worked in the past it might be something else. Please note that when putting KNIME workflows on a synced drive a lot of synchronization will go on, especially if you do a lot of editing. It might well be that some sort of sync conflict might arise. Maybe check for messages from the OneDrive console.

One idea could be to stop syncing while you work on a workflow and activate it again once you have closed KNIME.

If this problem persists you might want to create a Log file in DEBUG mode so we could further investigate

Hi,

syncing definitely is an issue.
I always pause syncing when I execute this workflow because sometimes KNIME just closes down during execution.

Many thanks for the hints!!

1 Like