Unable to use Send to tableau server

Hello, I have been using tableau server connector for months and it worked well until last week. I am getting error " Execute failed: item number mismatch" repeatedly, and my team have same problem as well. I am using KNIME Analytics Platform 3.6.1 version. Before I got the error, I didn’t make any change on the flow.

Currently I write into the TED files and published them manually into tableau server, however we have a bunch of files need to be published and it’s a pain to do it every day in long term. Does anyone know why this error occurs and how can I address it? Thank you!

1 Like

Hi @cynthiacam -

This is a new issue that we’re investigating. Others are running into it this week as well (see the bottom of this thread: Connecting Knime 3.6 with Tableau Node ExctractAPI error), so it’s definitely not just you.

We’re on it, sorry for the trouble.

Hi Scott,

Thanks for getting back! I saw the thread and seems that you are going to launch a new version to address some of those issues. Can you let me know your projection of when this error can be fixed? Do I have to wait until the new version released? Thanks!


Hi @cynthiacam -

Right now I’m not sure about ETA - it’s still not clear to us what may have changed on the Tableau side. Are you able to share what version of Tableau Server you’re using? That may help.

It’s my hope that this will all be resolved with the KNIME 3.7 release, but it would still be good for us to understand what has caused this sudden problem with the existing Tableau integration.

Thanks for your input!

Hi Scott,

The node back to normal from yesterday night. I am able to sending data to tableau server now. Still curious what cause this issue, hope it will be prevented in the future.

FYI, my tableau version is 10.5. Thanks for taking care of this problem!

Thanks for the update, and glad you’re back to normal again.

Hi Scott,

Just a follow up that the node “send to tableau server (tde)” doesn’t work again from this morning. I updated my KNIME to version 3.7, and tried again, but no luck. I also tried to send to tableau server (hyper), and it gives me error every time even though I selected “overrwrite” in configuration: “ERROR Send to Tableau Server (Hyper) 0:4215 Execute failed: Forbidden: The datasource ‘xxxxxxxxxxxx’ already exists and may not be overwritten without the ‘overwrite’ flag set to ‘true’. (Error code: 403007).” Can you help me look into it? Thanks!


Hello @cynthiacam -

Sorry that you’re still having trouble. I’ll try to reproduce the error on our testing server. Do you have a sample workflow that reliably reproduces your problem?

Hi Scott, I can’t provide the sample because it is credential. But did you try on your own to overwrite the file in tableau server using that node and any error?


Hi @cynthiacam -

So far I have been unable to reproduce this problem. I can publish (and overwrite) files directly to our Tableau Server using both the TDE and Hyper nodes. I’m using KNIME AP 3.7.0 on Windows 10.

The latest documentation for setting up KNIME to work with Tableau is here: https://docs.knime.com/latest/tableau_integration_user_guide/index.html. Is this similar to what you did when you configured KNIME?

Hi Scott. I can confirm a similar bug is still active on MacOS after following latest instructions. It is isolated to the send to tableau server (hyper) node. Hyper sources can publish, however that is it. TDE node works fine for overwrites, however, the node for hyper is not flagging the API overwrite arg appropriately it seems.

We use Tableau Server 2019.1.

edit: I should also state that abort and append options for the hyper node also do not work and throw the same flag issue.


Since last week I’ve upgraded to 2019.1 and also updated the system path for the Hyper node, however I’m not able to overwrite the data source. This is the error message:
ERROR Send to Tableau Server (Hyper) 0:145 Execute failed: Forbidden: The datasource ‘MSTR - Guarantee data S19’ already exists and may not be overwritten without the ‘overwrite’ flag set to ‘true’. (Error code: 403007).
Is there anyone who knows more about this error? Thank you!

Hi @cnic and @SS_TC -

Thanks for the feedback. It seems maybe there is something in the latest version of Tableau that has introduced a new problem. I’ll create a ticket and see what I can find out.

Hi @ScottF,

Can you share the ticket details here for us to track? We are also running into same issue with “Forbidden: The datasource ‘hyper_xxxxx’ already exists and may not be overwritten without the ‘overwrite’ flag set to ‘true’. (Error code: 403007).”

We are trying to append the datasource in batched process and it errors out after first iteration.


Hi @jaisonbabu -

In short, it looks like this issue happens if there are more than 100 datasources in the project, and the datasource which is supposed to be overwritten is not part of the first 100.

We’re working on a fix for this, but it isn’t available in the nightly build yet. I’ll post another update when that happens.

1 Like

Hi @ScottF,

Thanks a lot for the quick response. This is very helpful as it explains why our job ran fine last week and not this week as last week our projects had less than 100 data sources.

Is this the issue only specific with “Send to Tableau Server node”? We are in the process of building our own node using the Extract API. So does the custom node resolves this issue?


I believe this problem only happens with the Send to Tableau Server (Hyper) node. So long as you take into account paging of the “Query Datasources” REST call when you build your custom node, I believe you should avoid the issue.

1 Like

Thanks a lot @ScottF .

Hi @ScottF, I am experiencing the same error in Mac OS. There are only 29 datasources in our individual project, so not sure if there are any other issues blocking this? Can you please help? Thanks!

ERROR Send to Tableau Server (Hyper) 0:49 Execute failed: Forbidden: The datasource ‘xxxxx’ already exists and may not be overwritten without the ‘overwrite’ flag set to ‘true’. (Error code: 403007).