update 3.3 failed unable to read repository


I have this issue on different machines (Windows and also Mac). Another device (Windows) was able to run the complete update. But for now I receive on the Mac and the other Windows-machine (no admin rights) this error while trying to apply the update:

An error occurred while collecting items to be installed

session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Unable to read repository at http://update.knime.org/analytics-platform/3.3/knid=01-67cd6e1c804f8314/org/3.3/3.3.1/plugins/org.apache.tika.app_1.13.0.jar.

Read timed out

I don't think that this might be an firewall issue. Because I can download the jar-file, when I copy the URL into my browser (on both machines).


Can you help me, I can't be alone with this problem ;-)

Thanks in advance

A colleague suggested adding these settins to the knime.ini file. I added it belwo the -vmargs line. And it solved my problem on a large internal network getting strange messages when trying to update KNIME. From my understanding it basically increases the timeout for the operations.







Hi mlauber71,

Thanks. Unfortunately, this didn't work in my case. I had to download the whole new software and reimport the workspace.



This worked for me Thanks!


Solved my problem, thanks! :ok_hand: