Updating KNIME


I continue to encounter problems with updating KNIME, either updating the KNIME version itself, or updating Community releases. To get the new KNIME 2.5.2 release on required me to update the modules a couple at a time, choosing them all always results in an error. Same applies for community releases, they have to be done a couple at a time too.

Both myself and my colleagues encounter the same problem, and it occurs on my home PC too. Additionally, a number of participants at the KNIME UGM reported having similar issues in getting updates to go on.

I dont believe its an internet related issue. I have been watching the update process and notice that it always completes the downloads as it shows the total x Mb of x Mb has been downloaded. As soon as the internet download is complete, KNIME appears to do nothing for about 5 minutes and then reports the error. If KNIME gets as far as mentioning its committing the provision, then it will always work. Consequently the issue seems to arise somewhere between the download being complete and committing the provision.

I have played around with the xmx in the ini file from 512 to 1024 to 1536 without any improvement.

My PC is Windows Vista 32bit 3Gb RAM, and Office PC is Windows XP 32Bit 4Gb RAM.

I hope this can be rectified as it is very time consuming getting the updates to apply.



Hi Simon,

If you can exclude a connection problem then we should try to find out what KNME/Eclipse is doing in the 5mins after the download and before the error. Can you extract a "jstack" for us and attach it to this thread?

Here is what you need to do:


Hallo Bernd

I am experiencing severe problem in connecting for updating to knime 252 for Win 7 32bit

Here what I got

An error occurred while collecting items to be installed
session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).
No repository found containing: binary,com.knime.features.reporting.designer_root,
No repository found containing: osgi.bundle,org.apache.batik.css,1.6.0.v200912221622
No repository found containing: osgi.bundle,org.eclipse.datatools.connectivity.ui,1.2.0.v201006250003
No repository found containing: osgi.bundle,org.knime.chem.base,
No repository found containing: osgi.bundle,org.knime.chem.types,
No repository found containing: osgi.bundle,org.knime.ext.birt,
No repository found containing: osgi.bundle,org.knime.ext.chem.openbabel,
No repository found containing: osgi.bundle,org.knime.ext.itemset,
No repository found containing: osgi.bundle,org.knime.ext.poi,
No repository found containing: osgi.bundle,org.knime.ext.r,
No repository found containing: osgi.bundle,org.knime.ext.svg,
No repository found containing: osgi.bundle,org.knime.ext.webservice.client,
No repository found containing: org.eclipse.update.feature,org.knime.features.chem.types,
No repository found containing: org.eclipse.update.feature,org.knime.features.distmatrix,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.birt,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.chem.tools,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.itemset,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.libsvm,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.poi,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.r,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.svg,
No repository found containing: org.eclipse.update.feature,org.knime.features.ext.webservice.client,
No repository found containing: org.eclipse.update.feature,org.knime.features.xml,


Do I have to change something ?

It is definitively not an Internet provider problem. I tried this morning at 7, 12, 16 and 18.00




Hi Bernd,

I eventually got all the KNIME components installed doing it stepwise so I cannot attach anything to this thread at the moment, but the next time there are a few updates I will run the procedure you describe, as I now have Java JDK 6 installed.

Thanks for the instructions.


Hallo Bernd & everyone

I tried several time to update 2.5.1 to 2.5.2 on a Windows 7 PC (32bit knime version) with 4Gb RAM w/o success. From JDK I got the attached log with jstack as suggested. I noticed since beginning of the year a pulsatile fluctuation of my internet connection rate which sometimes brings timeout from remote. During non-busy time (morning e.g.) I could not, however, finish my update which indeed I managed for nightly update on 2.5.1 installation which actually remains my working horse.

Any suggestion?



Hi Bernd,

Okay, so still having issues with updating, only trying to update the KNIP and Indigo downloads at the same time.I allowed both to complete the download according to the progress bar and hovering over it to confirm the full size had come down.

I then ran the JStack process, and then again 3 minutes later which turned out to be literally seconds before the error message in KNIME arrived.

Attached are those JStack messages which mean nothing to me, hopefully more to you.



Hi Andrea,

Your jstack file suggests that a confirmation or progress dialog is open and waiting for some user interactions. Maybe some dialog was in the background that you didn't notice?

It doesn't have any http line in it, so I don't think it was downloading from (or attempting to connect to) the update site server.


Hi Simon,

Yes, these files are helpful. Both files show that some http connection was open and that content was being read (those magic line here: org.apache.commons.httpclient.ContentLengthInputStream.read(ContentLengthInputStream.java:170))

In your case it indeed seems to be a connection problem.  Thorsten was so kind to create a mirror update site on a different host. It's hosting the latest KNIME version (v2.5.2 as of today) and a daily updated copy of the community extensions. I'm going to send you the URLs by email as this machine has very loose firewall settings (we are curious if the firewall settings on knime.org are locking you out). Don't break it! :-)


I forgot to mention: If you add this new update site, make sure to remove or inactivate all the other update sites ("File" -> "Preferences" -> "Install/Update" -> "Available Software Sites", then uncheck all but the one that you really want to connect to, i.e. the ones I sent you or the zipped update site that you downloaded). Once that is done, check for updates by using "Help" -> "Check for Updates", do NOT use "Help" -> "Install new Software".  Reason is that Eclipse will try to connect to all registered updates sites, even if those were not specifically chosen in the "Install new Software" page.

Maybe we are overdoing things here a bit but let's get it working first and then we sort out the details?!

Hi Bernd,

I did as you mentioned and put in the new update sites and disabled the standard ones. I then checked for updates using "Check for Updates" and after proceeding with the update, the exact same problem occurred where it appeared to download the entire file, and then it pauses, doing what appears to be nothing for about 5 minutes before reporting the error below (Note I have starred out part of the URL you gave me so its not publicly available):

An error occurred while collecting items to be installed

session context was:(profile=KNIMEProfile, phase=org.eclipse.equinox.internal.p2.engine.phases.Collect, operand=, action=).

Unable to read repository at http://merk*******community-nightly/plugins/org.kniplib_0.5.0.201202221450.jar.

Read timed out

OK, this pretty much rules out server issues (good or bad, depending how you look at it...)  Did we already discuss if you are using some kind of virus scanner which sits between KNIME and the server and slows downloading so much that eclipse gives up?

Well, I have ESET Antivirus installed. Later I can try disabling it and see if this resolves the issue.


Okay, well even with the antivirus fully disabled, the updating error messages are still present.


Hi All,

as I am experiencing still problems in updating 2.5.1 to 2.5.2 through Help>update, and having strong evidences that opening special ports to download is not permitted or take so much time that timeouts are always there, I tried as well to disable AVIRA Security (e.g. firewall ) without success, I wonder whether your communication protocols might be targeting ports which are unallowed or unwelcomed by Internet providers like t-Com or others. Is this silly as a question?

Stuck user Andrea ;-)

I too am still experiencing problems with the updating facilities.


The update mechanisms is only using port 80 (the standard http-port).

Another thing you may try is to delete all foldes named "cache" underneath the "p2"-folder of KNIME. We also experienced some update problems this week which were caused by a slow and unstable connection in the austrian alps. Sometimes Eclipse seems to choke on this, deleting these cache folders seems to help then.

Hi Thor

in my case, I am sure that something has to do with bandwidth too.

However, I don't have cache folders in knime2.5.2./p2 and I keep on having problem with JVM_Bind.

Unable to read repository at http://www.knime.org/2.5/content.xml.
Bad address: JVM_Bind
Unable to read repository at http://merkur02.inf.uni-konstanz.de/update/community-nightly/compositeContent.xml.
Bad address: JVM_Bind

So I keep working on 2.5.1, even after one month having downloaded 2.5.2.



Just to let you know that this continues to be a problem.

I now know of so many other users who experience this issue with the updating.

It seems when you try and update lots of packages at the same time, this is when the errors occur. Updating a couple at a time gets around the issue.

I have noticed that problematic items for updating are; KNIME XLS Support, KNIME Public Server View, KNIME HCS Tools, and KNIME Image Processing. Trying to install these with other items usually results in KNIME failing with the install after some considerable time.

It is noteworthy that if the entire UpdateSite.zip file is downloaded and you use this for the update it is always successful. There is an issue in the updating process somewhere which is present in all KNIME versions.