Upload file with authentication cannot find file

I’m having trouble with the Upload file with authentication. It produces the following error: “ERROR Upload Files with Authentication 0:699 Execute failed: Cannot find file '(name of the file)”.

My workflow is located from a knime server. The flow reads a file from the company shared network using list files with authentication and downloads the files with authentication. I then make a few changes to the files and save them to the directory created by “download files with authentication”.

When I try to upload these files to the shared network using the above mentioned directory the node produces the “cannot find file…” error.

Any help please

I’ve also tried to create a temporary directory, that also didn’t work, it gave me the same error.

@tiaandp welcome to the KNIME forum.

It seems this upload with authentication node is from a third party environment. You might want to use the

Nodes. You will have to connect them to your (dark blue) connection connecting you to your company share and you will have to provide a Path variable. There is a node to help you create one (useful for external resources).

It might be beneficial if you would consult the extensive KNIME File handling guide (yes it is large but you will understand how KNIME is -well- handling files and paths):

https://docs.knime.com/latest/analytics_platform_file_handling_guide/index.html

Another useful thing could be the KNIME Cheat sheet about connectors. So you might choose the right track when dealing with external connections. It still will require some trial and error sometimes. And please note the KNIME server might need its own connection in order to handle files there.

2 Likes