Use of Matlab Snippet

Hi everyone,

I tried to set up the Matlab node in a dummy workflow to see if my setup together with matlab 2015b works. It doesnt do much, just giving a value to kIn and mOut.

I was brwosing through some older posts and found that there might be an access problem, which is why I ran it as an admin. Trying to set an environment variable for matlab didn't work out either so far.

One point that I'm unsure of is which configuration I have to do in the KNIME preferences. The node description of "Matlab Snippet" says there can be a link to a template file. However I don't really know what a template file would do in this context and how to make one. Does it have to do with the R GUI Gnerator? I read that as an optional thing in the node description. Also I don't really need it since matlab code is fine with me and I don't need the graphical representation.

The error code shown is the following:

WARN  KNIMEApplication$3              Potential deadlock in SWT Display thread detected. Full thread dump will follow as debug ouput.
WARN  XLS Writer           0:1        Output file '\\SI01FS08.de.bosch.com\DS_Web30$\20_PJ-CO\10_Team-Members\Maisenbacher\test.xls' exists and will be overwritten
WARN  Matlab Snippet       0:4        [https://raw.githubusercontent.com/knime-mpicbg/scripting-templates/master/knime-scripting-templates/Matlab/script-templates.txt does not contain any valid template or cannot be accessed.]
ERROR Matlab Snippet       0:4        Execute failed: Support code location could not be determined. Could not convert from URL to URI location.
URL Location: file:/C:/Program Files/KNIME/configuration/org.eclipse.osgi/76/0/.cp/lib/matlabcontrol-4.1.0.jar
Code Source: (file:/C:/Program Files/KNIME/configuration/org.eclipse.osgi/76/0/.cp/lib/matlabcontrol-4.1.0.jar <no signer certificates>)
Protection Domain: ProtectionDomain  (file:/C:/Program Files/KNIME/configuration/org.eclipse.osgi/76/0/.cp/lib/matlabcontrol-4.1.0.jar <no signer certificates>)
 null
 <no principals>
 java.security.AllPermissionCollection@4acae405 (
 ("java.security.AllPermission" "<all permissions>" "<all actions>")
)


Class Loader: org.eclipse.osgi.internal.loader.EquinoxClassLoader@30e8727e[de.mpicbg.knime.scripting.matlab:3.1.0.v201602120920(id=76)]
Class Loader Class: class org.eclipse.osgi.internal.loader.EquinoxClassLoader

One part that I don't understand is that the matlabcontrol-4.1.0.jar can't be found. It is in exactly the same location where the path is loking for it.

Any help is greatly appreciated!

Should you miss any piece of information please let me know.

 

Kind regards,

Lefty

 

Which version of KNIME and the Matlab-Scripting-Plugin are you running?

The error message points to a problem with the space in the installation path of KNIME. The nightly build of the Matlab-Scripting-Plugin should contain the fix for that problem.

A workaround is to install KNIME at a location without any space in the installation path.

Does that help?

Thank you for your suggestion!

I was running KNIME 3.1.2.

I updated to 3.2.1. and installed the nightly community nodes from the zip-file. That allone didn't work.

However I'm happy to report that the workaround you suggested did in fact solve the problem. Matlab is starting up nicely.

Thank you kindly!