Using auto-install.xml does fail for us in 4.7.2 but works fine in 4.7.1 - any idea?


#1

Hello everyone,

in order to prepare for the oncoming 4.7.3 we wanted to rework our server installation procedure (DEBIAN) and we realised that we have a problem with 4.7.2 while it did work fine with 4.7.1.

What we did:

  1. manually installed: java -jar /opt/knime_server/knime-server-installer-4.7.2.jar

  2. afterwards created auto-install.xml

  3. stopped all KNIME processes

  4. delete KNIME: rm -rf /opt/knime_server

  5. run autoinstall: java -jar /opt/knime_server/knime-server-installer-4.7.2.jar /root/auto-install.xml

  6. failed with the following reason:

     **************hidden servername*********** 20180911-13:22:32 ~
     # java -jar /opt/knime_server/knime-server-installer-4.7.2.jar /root/auto-install.xml
     Command line arguments: /root/auto-install.xml 
     [ Starting automated installation ]
     WARNING: AutomationHelper class not found for panel class: com.izforge.izpack.panels.knime.ExtendedJDKPathPanel
     [ Starting processing ]
     Starting process Installation of KNIME Executor (1/1)
     [ Starting processing ]
     Starting process Extracting temporary 'director' application (2/5)
     Starting process Querying content of update sites (3/5)
     Retrieving Installable Units from 
          o http://update.knime.com/analytics-platform/3.6/
          o http://update.knime.com/community-contributions/trusted/3.6/
    
     SEVERE: Cannot run program "${jdkPath}/bin/java": error=2, No such file or directory
     [ ERROR: Cannot run program "${jdkPath}/bin/java": error=2, No such file or directory ]
     [ Processing finished ]
     [ Processing finished ]
     [ ERROR: The work done by the ProcessPanel (line 21) failed ]
     [ Automated installation FAILED! ]
    

If we run the same xml with 4.7.1 installer it runs through.

auto-install.xml (3.2 KB)

Any idea to solve the problem is appreciated!

Thanks a lot
Lars


#2

Hi Lars,

Can you share the location of your Java JDK and the JDK location setting in the autoinstall.xml?

Thanks,

Jon


#3

Hi John,

I hope that’s what you requested:

# grep jdkPath /root/auto-install.xml | grep -v jdkVarName
<jdkPath>/usr/lib/jvm/java-8-oracle</jdkPath>
# file /usr/lib/jvm/java-8-oracle/bin/java
/usr/lib/jvm/java-8-oracle/bin/java: ELF 64-bit LSB executable, x86-64, version 1 (SYSV), dynamically linked, interpreter /lib64/ld-linux-x86-64.so.2, for GNU/Linux 2.6.9, BuildID[sha1]=c90f19ee0af98c47ccaa7181853cfd14867bc931, not stripped

The XML we used was attached in the previous post.

We are just wondering what might have changed from 4.7.1 to 4.7.2 since we are not aware that we might have changed anything but the installer file.

Thank you!
Lars


#4

Hi Lars,

We identified the issue and have a fix that we’re now testing internally. We’ll put that out in the 4.7.3 official release in the next couple of days.

Best,

Jon


#5

That’s great news! We are looking forward!

Thanks a lot!

Best,
Lars