Using String Manipulation to get rid of parentheses @ 3.7.1

Dear all,
I’ve used Node String Manipulation (replace function) to get rid of the parentheses which the data read from an excel.
It works well at 3.6.X. with the expression of " replace(replace($ColumnValues$, “(”,"" ), “)”,"" ) "
However it does not work when I updated to 3.7.1. It seems that the symbol “(”and “)” will lead to an error. The error information can refer to the picture below.
I tried to use cell splitter to split “(”and “)”,but it will be reported error when the content is empty after read from excel.
Anyone can help to solve this?

My original target is get rid of the parentheses in a work flow no matter the former step is empty or not.

Thanks in advance,

I have seen this happen too. Unfortunately I don’t have a solution, and I suspect it it’s either a bug or an incomplete update of KNIME. You could try checking for updates and installing them and see out that fixes it.

Hi there!

I have just tried it out in 3.7.1 version and works for me when I write my own replace function but when copying your expression it does not work. If not mistaken the issue comes from a different types of quotes…

Check the difference between yours and my function in print screen.

If you still have error after changing quotes can you share sample workflow where this behavior can be checked?


Thanks Ivan - that does look like a difference, but certainly in my case the workflow was OK in 3.6.x, and only stopped working when it was update to 3.7.1, so not really sure what or why is happening here.


Hi Ivan,
Thanks for your reply. My work flow works again!!!
However, yesterday I tried a lot including restart Knime & PC, but didnot work.
It seems that maybe the I’ve used to much Node of String Manipulation that they need a rest :slight_smile:

Hi Steve,
Turn off your PC and taking a coffee, maybe it will work when you come back LOL


1 Like

hi there!

Glad it works now @kevinchen :slight_smile:

@s.roughley can you share a workflow to check it?


Unfortunately not - it was a demonstration workflow which I no longer needed thus deleted it!


Hi Steve!

I see. If you come across something similar drop a message here.