v4.7 Heap Issues on Apple Silicon

Further to this locked thread: How to adjust heap size in v4.7.x?

My system was working well without an explicit heap setting until today. I was able to do all my work as before on the Intel version, but about 50% faster throughput.

Today I tried to update a 95MB Excel file with the Excel Writer node and got a heap error. The heap would extend to ~8GB by itself but no further. My Mac has 32GB of RAM, so I expect that it should/could extend further. Not sure if the built in heap setting has been increased from 2GB to 8GB or not…that’s my best guess.

Screenshot 2023-01-27 at 11.08.52 AM

I was able to work around the issue manually with separate Excel files, but will be good to get a handle on the heap settings as soon as possible.

Screenshot 2023-01-27 at 11.09.32 AM

Thanks – Andrew

@AndrewDevlin I would assume you could still set the heap size per change in the knime.ini.

1 Like

Do you mean manually add the line from the old ini file?

That would be my suggestion.


I have Apple ARM CPU and for running KNIME with more RAM I using in KNIME.INI this params:


For acceleration string operations I using in KNIME.INI this params:


For acceleration Column operations I using in KNIME.INI this params:


Well, You can to try it. :grinning:

I use KNIME for Data analytics in Cyber Security and my tasks need more RAM and CPU speed.

Karel Simecek


Update – I added the line


to my knime.ini in v4.7 and it fixed my issue. I am now able to address more than 8GB of real memory.

Screenshot 2023-01-31 at 1.35.09 PM

@knime team: this should be added to the closed thread referenced above as a solution as well.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.