Variable loop End - Executed failed

Hi everyone,

I have an issue with a variable loop End. I have got this error :
ERROR Variable Loop End 2:49 Execute failed: Output table’s structure differs from reference (first iteration) table: Column 3 [2T2019 SALES (Number (integer))] vs. [2T2019 SALES (String)]Column 4 [2T2019 PRICE (Number (integer))] vs. [2T2019 PRICE (String)Have the input variables changed in number, name or type?

I don’t know how to solve that.

If you can help me, I will be very grateful.

Hi there @Grayfox,

columns 2T2019 SALES and 2T2019 PRICE in one iteration were String in other Integer type. Check where the type is defined. You can use Step Loop Execution option from Variable Loop End node and inspect nodes in loop.



@ipazin Thank you for your answer.

So I tried to use the Step Loop Execution but the execution stop at a specific moment, but I don’t know why.

In my worflow, I use an excel file as model, and copy this model repeatedly to create mutiple files by country.
After I use a loop to filter in a data file to choose my country and insert the line into my model.

All the process work, the model is copied, the filter work also, the datas have been copied but for one country, it don’t work. I don’t knwo why.
The type is not changed, so why it’s working for a file and not for an other ?

Hi @Grayfox,

it is a bit hard for me to understand what are you exactly doing and what could cause this issue. If you can share workflow that would be great. If data is confidential you can mask countries and leave only one numeric column so issue is reproducible. Otherwise maybe some screenshots could help.


I found where the problem is. It’s from a missing value in my data. So i replace the missing with a 0 and it’s work.

Thank you for the helping.

1 Like

Hi there,

glad you solved it.


This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.