Web Interaction Nodes

Hi community,

I´m trying to use Web integractios nodes to open an URL through a Firefox browser and I need to apply proxy setting to the browser. I have created a profile named “knime” with proxy settings and in the Web interaction Start I select Firefox Browser and in advanced settings, in command line aguments add -P “knime” to force the right profile.
Doing this, the browser opens with correct proxy setting but the node crashes. The node progress bar never gets the 100% and the flow can´t progress.
Can someone help me on how to solve the general problem?

Thank you very much¡¡¡



Thank you for trying our new Web Interaction nodes! Good point about the proxy settings. To be honest, we missed testing this use case.

However, we are currently working on making proxy settings available in Python-based extensions (such as the Web Interaction extension). Would you mind trying out a few settings to help us fixing this in the future?

Which operating system are you on? Could you try configuring the proxy as environment variables (using HTTP_PROXY or HTTPS_PROXY for linux/mac or windows), running KNIME and then using the web interaction nodes?

If you are on Mac, let me know, then you need to start KNIME differently to make sure it propagates environment variables.

Going via the profile in Firefox is an interesting idea, but we have never tried this. If we can’t solve the problem via environment variables we could have a look at this approach in our development setups.



Another option would be to pass the proxy setting to the browser as command line argument in the Web Interaction Starter node. However, it looks like this isn’t easily possible with firefox. If you don’t mind using Chrome/Chromium instead, this one has an option --proxy-server= that you could try.

Hi Carsten,

thank you for your answer.

I have configured system variable in my windows environment. I have configured https_proxy, https_proxy_user and https_proxy_password and I have restart windows and opened knime. Then I have try Wed Interaction Star and Navigator node to acces de URL, but it hasn´t work.

I have tried it with Create Firefox Browser Instance from community nodes/AF Utilities/Firefox Util and I have achieved it after configure firefox preferences with






This is a good solution for me, but I love the Selenium REcorder PLayer Node in Web Interactions Nodes and I would like to have the possibility of using it .

Now I´m going to review your second mail.

Thank you.


Hi Carsten,

I could swear I had tried this and it didn´t work but I have tried it again a “voila¡¡¡¡” it works in chrome¡¡¡ :+1:

In firefox doesn´t work.

I think in firefox the solution using a profile should be good. In fact, when I try the -P knimeprofile in de Command Line Arguments in Web Interaction Starts Node, I get a Firefox instance with network proxy settings correctly configured, but the node gets stuck and the flow does not progress.

It´s OK for me, thank you very much for your help. If you need me to perform any test related to this issue in future do not hesitate to ask.




I’m glad to hear that it works for you with Chrome!

This is exactly how we think it should work :slight_smile:

We noticed that there is a programmatic way to set the proxy for firefox, so that users do not have to set up their own profiles. We’ll create a development ticket to propagate the proxy settings to the browser properly and will let you know once that is done.


1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.