Webdriver starts but then shows unknown error - result.webdriverValue.value

Hi @qqilihq ,

Today I upgraded my KNIME to version 4.7.7 and when I re-open a workflow I had running perfectly fine in version 4.7.2 I had some errors.

First with the “Webdriver Factory”, that gave this errror:

After looking into this topic I found a workaround that seemed to have worked.
I ran “knime.exe -clean”

After restarting KNIME I tried again and this time the Webdriver starts fine:

But then I when I tried to run th eworkflow in the first “Click” Node I got this strange unknown error in the Outline:

unknown error: result.webdriverValue.value list is missing or empty in Runtime.callFunctionOn response
  (Session info: chrome=119.0.6045.105)
Build info: version: '4.14.1', revision: '03f8ede370'
System info: os.name: 'Windows 11', os.arch: 'amd64', os.version: '10.0', java.version: '17.0.5'
Driver info: org.openqa.selenium.chrome.ChromeDriver
Command: [881a02ba8866afc0ec369297a0898e05, executeScript {script=window.nodes = [document], args=[]}]
Capabilities {acceptInsecureCerts: false, browserName: chrome, browserVersion: 119.0.6045.105, chrome: {chromedriverVersion: 118.0.5993.70 (e52f33f30b91..., userDataDir: C:\Users\BRUNO~1.CAD\AppDat...}, fedcm:accounts: true, goog:chromeOptions: {debuggerAddress: localhost:63208}, networkConnectionEnabled: false, pageLoadStrategy: normal, platformName: windows, proxy: Proxy(), se:cdp: ws://localhost:63208/devtoo..., se:cdpVersion: 119.0.6045.105, setWindowRect: true, strictFileInteractability: false, timeouts: {implicit: 0, pageLoad: 300000, script: 30000}, unhandledPromptBehavior: dismiss and notify, webauthn:extension:credBlob: true, webauthn:extension:largeBlob: true, webauthn:extension:minPinLength: true, webauthn:extension:prf: true, webauthn:virtualAuthenticators: true}
Session ID: 881a02ba8866afc0ec369297a0898e05

Also noticed that when I run the “Start Webdriver” I get this warning:

WARN  Start WebDriver      3:16       Could not extract source from ChromeDriver: chrome on windows (8edc006aeaa376cb1f340525d0790209)

Any insights on what might have went wrong here?

Kind regards,

Hi Bruno,

  • Are you using the newest version of the Selenium Nodes? Can you please double check this through the “About KNIME” window?

  • The entries in the “Capabilities” section do not really make sense - “item 1” is not a proper capability - thus you can simply remove it without any side-effects.

  • Can you please try with the bundled “Chrome for Testing” WebDriver? (if it’s not available in the menu, please install it through the “Install Software” dialog)

Best regards,

Hi @qqilihq,

Thanks for the quick reply.

  • I confirm I ahve this version installed:

  • I have now removed the "Capabilities"line

  • I have installed the Chrome for Testing Bundle and did a test with it and it works fine:

  • For the same url this is what I get when I try to use the “normal” Start Webdriver:

Might it be something related with the Chrome Version?

Hope this helps.

Kind regards,

1 Like

Hey Bruno,

many thanks for the details.

Indeed it’s most likely cased by the Chrome version, if it still fails when you select the normal “Chrome” in the settings. Could you please double check which version it is? It should currently (as of Selenium Nodes 5.2.1) be 118 - other versions, older or newer might cause issues.

Exactly due to that we provide the “Chrome for Testing” which is distributed with the nodes. This version is always guaranteed to be working with the nodes - independently of the version installed on the system. This also makes it ideal for Runner, Server, or Hub environments. See also here.

Best regards,

1 Like

HI Philipp,

Makes sense, indeed I have Chrome version 119 on my system.

Okay I will work with the “Chrome for Testing” until there is a new update on the Selenium Nodes.

Thanks for the help and the explanation.

Kind regards,

1 Like

Update: Version v5.2.2 fixes this for Chrome 119.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.