WebPortal “Something went wrong” cache problem

Dear KNIMErs and KNIME Server/WebPortal users,

Since we updated to the new server (4.16.5) some time ago we’re facing some strange cache-related issues. If we leave the browser (both Chrome and Firefox) open in some workflow directories of the WebPortal, after a while (probably when the server disconnect) we receive a “Something went wrong” message (see screenshot) and the WebPortal workflows cannot be accessed anymore.

Luckily, we found that the error can be solved by clearing the cache of the browser but this is something that it’s not trivial for all the organisations’ members.

We never experienced such a problem with the previous versions of the server.

What is it due to? How can it be solved?

Thanks in advance for your help.



Hello @gcincilla ,

currently we are not aware of any general problem concerning the 4.16.5 WepPortal. At the present state of this issue it would be really hard to narrow down what could be the root cause (network problem, some browser plugin?) since it is not reproduceable.
I would suggest to monitor this issue and when it happens again check the browser console (hitting F12 in Chrome) and see if anything interesting or helpful is there. Also when it happens gather as much information as it is possible (e.g VPN is used or not, are there any specific network settings, http or https is used, is there any browser plugin used, what is the type of the user login (LDAP, SSO, local knime user) etc.) and open a support ticket for the investigation (https://www.knime.com/support)

Best regards,

Hello @dora_gcs, thank you for your reply.
Yes, the VPN is used when the problem appears. It happens every time I leave a KNIME WebPortal page opened for a certain time.
I’ve tried to inspect the page upon the error, and this is something that got my attention (see screenshot below).

Does this help to solve the problem?

In a new case of the same problem, I’ve got these errors:

info Using REST service at https://app.prod.knime.healx.dev/knime/rest/v4/
entry.482433d0.js:1 TypeError: Cannot read properties of undefined (reading 'isNuxtError')
    at sa.fn (error-component.96117577.js:9:827)
    at sa.run (entry.482433d0.js:1:5091)
    at get value [as value] (entry.482433d0.js:1:14208)
    at sa.fn (error-component.96117577.js:9:950)
    at sa.run (entry.482433d0.js:1:5091)
    at get value [as value] (entry.482433d0.js:1:14208)
    at setup (error-component.96117577.js:9:976)
    at Jr (entry.482433d0.js:1:14430)
    at nk (entry.482433d0.js:1:66605)
    at qb (entry.482433d0.js:1:66390)

Hello @gcincilla ,

Sorry for the late reply here!

We have discussed this problem internally and believe that it is a network issue on your part and not necessarily related to WebPortal. ERR_NETWORK_CHANGED strongly suggests this.

Is it possible to try using WebPortal without a VPN? Is there any difference?
If this problem occurs, is it always necessary to clear the cache to resolve it, or does refreshing the page work to fix the problem?

Thank you!

Hi @dora_gcs,
Thank you very much for your reply and for pointing to a network issue. We appreciate this because we’re still experiencing the problem.
Regarding your questions:

  • Unfortunately I cannot use the WebPortal without a VPN so I don’t know if there is any difference.
  • When the problem occurs it is always necessary to clear the cache to resolve it. Refreshing the page does not fix the problem.

Is there anything you can think of that we can try to solve the problem?

Hello @gcincilla ,

thank you for your response!
We’ve discussed it internally many times and I’m afraid I can’t suggest anything that would solve the problem.
We believe from our side there is nothing we can do about the issue and we can not reproduce it either. At the moment we can only suggest to have someone on your side to look into the network / VPN setup a bit closer to see if there is something that can be done there.

Sorry for being such a little help!

OK @dora_gcs, thank you anyway for your help.
As you suggested, I will try to have someone on our side to look into the network / VPN setup. I’ll update this thread if I have any useful info.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.