WebPortal URL parameters do not work

I want to have a link to my application that right away starts the application, without clicking RUN. And I want to see what the experience is if I use the & single option.

I tried to follow KNIME WebPortal User Guide.

However, putting &run or &single does not work. Anyone knows why?

Thanks for hints

Hello @d00m ,

the attached user guide is quiet old (referring to KNIME Server/WebPortal version 4.10).
Please find here the latest one: KNIME WebPortal User Guide

If you want to run the workflow without hitting the ‘Run’ button you need to use the ?exec, as it is stated in the documentation:

?exec redirects to the automatic execution of the workflow

According to the documentation I’m afraid the &single option is no more available.

I hope it helps!

Great, thanks. the ?exec works just fine. even the &fullscreen. Shame on me I did not look twice to use the latest version of the guide.

I got an additional question: Can I embed the WebPortalWorkflow into a sharepoint page?
I copied the embed code from the sharing option and pasted it in a sharepoint page for embedding pages. The below error comes. Can it be a setting on on of the two sides, SharePoint / KNIMEWebportal that hinders the AZURE connection?


This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.