What version of tensorflow should I install?

Hi,

I have a question about the version of tensorflow for using deep learning nodes in KNIME.

When I installed tensorflow version 2.2.0, I got following message.
“Library tensorflow is installed in version 2.2.0, required minimum version is 1.0.0 (inclusive), required maximum version is 2.0.0 (exclusive)”

When I installed tensorflow version 1.14.0, I got following message.
“Library tensorflow is installed in version 1.14.0, required minimum version is 2.2.0 (inclusinve), required maximum version is 3.0.0 (exclusive)”

What version of tensorflow should I install??

Thanks.

Hi @zhddhkdn,

That depends on whether you want to use nodes from KNIME’s Keras integration (which requires TensorFlow 1) or from KNIME’s TensorFlow 2 integration (which requires TensorFlow 2).

Marcel