When using scheduled Workflow execution, is it possible to enable the View of the results as if the execution was manually triggered in WebPortal?

#1

Hey guys,
basically, I created a really quick workflow to periodically check up on some things (e.g. every hour).
All the automatically executed instances show “Workflow executed successfully” in KNIME WebPortal, but not e.g. the Table View nodes that I had configured to display some information.
Basically, I want the scheduled execution instances of a workflow to also display the view nodes I created, after successful execution.


I know that there’s a workaround, e.g.: to create an extra layer of persistence with some sort of database and then create dedicated “Viewing” workflow to visualize the gathered info, but that requires more time of course. I want to know whether I can use KNIME server for something quick+dirty like I mentioned.

Thanks!

0 Likes

Knime web portal text output not working properly.
#2

Hi @pcps-afa

so you have a scheduled workflow, where you are saving the job.
This workflows does have a component and inside the component there is a Table View.
If you open the job on the webportal, you are on the last page, hence you would need to go one page back to see the table view.

Is this all correct?

If yes, the only option to have the table on the last page without the need to go back is to have a report. Reports are shown on the last page. Would this help?

Cheers, Iris

0 Likes

#3

Hi @Iris,
thanks for the quick reply.

Yes - I’ve got a scheduled workflow with a single component, in which there is a Table view.
My Workflow looks like this:

Basically, I don’t have a component to do certain inputs; all parameters are hard-coded in the config of the nodes. I just want the workflow to execute again and again over time and visualize the results in a table in the Webportal Jobs.

I tried your suggestion with the “Back” button, but that then sadly discards the job :frowning:

I’d like to get it working without having to configure the report.
But if there’s no other chance, then I guess I’ll have to do it that way :wink:

Thanks & BR
Alex

0 Likes

#4

Hi Alex,

yes you are right. I have to admit I never tested this. I will open a bug report for this one.

So the Report would be my only workaround I can offer right now.

Best, Iris

0 Likes

#5

There is a fundamental difference in the execution mode of workflows when started from the Analytics Platform and from the WebPortal. In the former case the job is run in a faster mode and no wizard pages or views will be available. Only when started from the WebPortal pages and views are available. Hence it’s not possible to schedule a job and then go to the WebPortal and attempt to go back one page. This is not a bug this is how the two different execution modes work.

1 Like

#6

@thor @Iris
Thanks for the insights! I guess the matter is settled then - I now know that I’ll have to find another way for my use case.

BR Alex

1 Like