Why can't input Chinese

I used Mac book, why can’t input Chinese in any nodes? But can copy Chinese word into node.截屏2021-05-04 20.11.16

Hi @eddy0620 , I am not sure why it is not working for you, I just tried pasting some Chinese characters that I copied off the internet and it works for me:

@eddy0620 it might very well be that you have to set a different encoding (UTF-8 or UTF-16):

1 Like

Hi @mlauber71 , character encoding is definitely the first thing that came to my mind (UTF-8 should be sufficient here), but I did not go into this direction because:

  1. From @eddy0620 's screenshot, the Chinese characters displayed
  2. There isn’t any preferences in Knime to set your character encoding to UTF-8
  3. It worked for me with Knime’s default preferences

Based on these 3 points, I assume that Knime inherits your system’s character encoding, and from the screenshot, @eddy0620 's system’s character encoding seems to be properly set since we see the Chinese characters.

Looking at the screenshot once gain though, I can’t tell if the Chinese characters are indeed displaying, or is that just an image with 9 Chinese characters in it.

@eddy0620 your system’s character encoding is usually set based on your system locale.